Forums > Dev

Using Xcode project made with Max5 SDK with Max6 SDK

November 22, 2011 | 5:00 pm

Hello,

I’m a beginner with externals Xcode. I copied my external folder from max5 SDK to max6 SDK and I’m facing some problems while building the project (it builds correctly in max5 SDK) :

- ERROR "Build setting PRODUCT_NAME undefined"

- WARNING "The file "maxmspsdk.xcconfig" couldn’t be opened because there is no such file. (/Applications/MaxSDK-6.0.1/examples/audio/maxmspsdk.xcconfig)". Indeed, this file is not at this path.
The MaxAPI.framework, MaxAudioAPI.framework and maxmspsdk.xcconfig are red in Xcode, so i dragged and dropped the correct files from MAX6 API to Xcode, I deleted the former ones. Now, they are recognised (not in red anymore) but i don’t know if this is the correct way to do it (the warning disapeared).

Lionel

Xcode : 3.2
Mac OS X 10.6


November 23, 2011 | 10:41 am

Thank you for the advices Vanille

You can drag’n'drop files, but i prefer to use right-click on the project window and go with "Add / Exisiting Frameworks" and so.

Ok, thanks, that works

Anyway It seems you have problems with your project settings.
While you have "maxmspsdk.xconfig" in your project, you need to open "Project / Edit Project Settings" window and select it in the "Based on" menu button ; do it again with "Project / Edit Active Target" …

I don’t have that "Based on" menu button in my Xcode version.

I still have this "Build setting PRODUCT_NAME undefined" error, if somebody has a suggestion, please let me know …


November 25, 2011 | 10:13 am

Oh thank you very much, it’s building without error now since I chose Maxmspsdk in the "Based on" menu.

you don’t have something like that ?

Actually, i had missed this Based on Menu last time, it’s "hidden" in a corner of the window in my Xcode version …

Thanks again …


Viewing 3 posts - 1 through 3 (of 3 total)