Forums > MaxMSP

utf formatting of colls on mac not working

November 27, 2010 | 11:34 am

Hi all,
I have a problem saving and reading a coll. I wrote a line to a coll
controller, schön;

ö is a mutated vowel in germany but in general it shouldn’t be any problem for Max because it uses for all text the utf-8 encoding.

So I saved it as a file with the ending .mms
1testcoll_new.mms
This I cannot load (max-window):
1testcoll_new.mms: bad magic number
coll: error reading 1testcoll_new.mms

Then I changed the filename to "1testcoll_new.mms copy"
and the read-process was successful, no error.

On Win XP/Max 5.1.5 I dont have this problem.

But on my mac it is crazy…
Max 5.1.5
Mac 10.6.4
2.5 GHz Intel Core 2 Duo
4 GB 667 MHz DDR2 SDRAM

I think the interpretation of fileextensions in the coll-object on the snow-leopard guides to this problem, but I am just guessing.

Can anybody confirm this behaviour?

I am grateful for any help!

Best
Johannes

– Pasted Max Patch, click to expand. –

December 13, 2010 | 9:55 am

Hi again,

also with 5.1.7 the case did not change…
can anybody reproduce on the system-environment described above?

I made a more specific patch to show exactly the steps in detail.

Thanks in advance!
Best,
Johannes

– Pasted Max Patch, click to expand. –


Ch
December 13, 2010 | 1:15 pm

hi,

I can reproduce on 10.5.8 with 5.1.6
and it works if I remove the loadbang and message to max,
or if I replace it by [; max system macintosh fileformat .mms TEXT]
So you’re right, it seems to be related to file extension association.


Viewing 3 posts - 1 through 3 (of 3 total)