Values of my presets are not reloaded when I reload an ableton live set :-(

Mar 1, 2013 at 5:19pm

Values of my presets are not reloaded when I reload an ableton live set :-(

Dear all,
I am facing a very strange issue that it is very hard for me (I am a dummy) to solve or find a direction to debug :-(
I am building a sequencer -> M4L Drum box v2.8

I usually have a preset box where users can save their presets into.
They save their live act and reload it… oki fine.. Ableton live relaod the live act with Patches…
but then the preset box inside my M4L patch is empty!

It is like if ableton live did not save the presets while saving the whole live act…
Do you have any hint?

I use autopattrn, etc.. it usually works but since few version I developped .. I got this NEW bug :-(

#66797
Mar 1, 2013 at 5:54pm

Show us the code you are using to create the presets

-A

#240460
Mar 1, 2013 at 6:10pm

Oki, I send you this in a sec :-)

#240461
Mar 1, 2013 at 6:14pm

here is the code:

– Pasted Max Patch, click to expand. –

note that I have aslo bpatcher.. and inside I put the command “autopattrn” … no arguments, just this “word’.

thanks for your help!!!!!

#240462
Mar 1, 2013 at 7:05pm

All of your pattrstorage and preset object settings look right.

I added a multislider object and gave it a scripting name, and created a few presets in an MFL device in Live 9 using Max 6.1

They restored fine in the live set after I saved the set, quit Live and reopened it.

Cheers

-A

#240463
Mar 1, 2013 at 7:29pm

oki :-)
hum, I am going to make some rolback on my patch to see at which point something added has put the mess.

1- Do you know any issue with Bpatcher and Autopattern command inside?

2- I checked the document about this, not sure that autopattern is limited.. hum…
Is their any limitation with M4L about pattern storage?

#240464
Mar 1, 2013 at 7:39pm

If you are using autopattr you’ll need to have one inside your bpatcher abstraction, but it should work fine.

If you can show otherwise, please send us the whole device

Cheers

#240465
Mar 1, 2013 at 10:24pm

I found a workaround,
I can not really understand why I have this issue but let me explain what I did to overcome the situation for the moment.
The thing is very strange:
M4L (or ableton) seems that at a certain point it saved into the Ableton Live Set some EMPTY presets :-(
Even though I reload the presets files that I previoulsy saved… each time I quit ableton live.. re open ableton live.. my presets were empty!

The only way to overcome this situation was to reopen my preset file, re STORE all my presets .. Save Ableton Live Set once more and then it worked… (next time I open ableton live, the presets appears fine, automatically reloaded)

hum…

Anyhow, thanks a lot for spending the time to try to test and solve my “mini” patch! cool!
:-)

what is strange is that, M4L, should save the presets within

#240466
Mar 1, 2013 at 10:28pm

Maybe it’s the “initial enable” setting you have checked in the pattrstorage object.

Cheers

-A

#240467
Mar 2, 2013 at 9:10am

indeed! I set recently “initial enable” to on/off… Can’t remember now ;-)
Thanks!!!

#240468
Apr 23, 2013 at 8:00am

I am having the same problem. I’ve tried to add a pattrstorage object to my device, set initial enable to 1, autoupdate parameter to 1, but still the preset object is empty when I reload my set. Any solutions much appreciated!

– Pasted Max Patch, click to expand. –
#240469
Apr 23, 2013 at 8:51am

Found the solution: Once I added an autopattr object to the patch, everything worked out very nicely :-)

#240470
Jul 15, 2013 at 1:18pm

I am having a similar problem. I create a patch that contains a preset. I set it to save with patch. Then I make a larger patch that includes several instances of the subpatch. I change presets in each instance but when reload the larger patch, none of the preset values are recalled.

#256124

You must be logged in to reply to this topic.