Varispeed Recording Question.

Jan 22, 2011 at 10:25pm

Varispeed Recording Question.

I’ve built a looper using groove~ for the playback and poke~ for recording.
The record index is driven by the right output from groove~.

The speed of playback is adjustable and the way it is set up you can record what you can hear into the buffer at any speed, which is what I want.

The only problem is that a sound recorded at a higher speed will sound poor when played back at a lower speed.

I tried out ipoke~, but I think that you have to start recording from an index of 0 or it doesn’t work. I want to skip around a bit so I don’t think it’ll work for my needs.

I’m wondering if there’s a standard solution for this kind issue? Recording into a temporary buffer and copying it or something? (maybe with ipoke)

As a workaround I put the sample rate up to 96000 and this made it sound alot better but obviously there is a massive performance hit for signal rate stuff.

Can anyone give us a clue? Thanks

#54541
Feb 2, 2011 at 2:55pm

Hmm now at the point where I need to work at a normal sample rate so I’m looking at ipoke~ again. Can anyone help me with it?

I can’t get it to behave how I expect and I’m not sure why. It won’t seem to record into all sections of the buffer. At first I thought it was interpolating but now not so sure. If I start recording when the recordhead is near the end of the sample it leaves silence between 1000 and 2500ms. Just don’t get it aargh!

I’ve attached this patch which uses poke and ipoke simultaneously – ipoke doesnt seem to update the buffer window in realtime – is this normal?

Last point – the buffers are 5000 ms long but I only use the first 4000 – this is so I can set the recordhead to a non essential part of the buffer when not recording (sending -1 seems to crash ipoke/Max)

– Pasted Max Patch, click to expand. –
#196437
Feb 9, 2011 at 9:57am

Just in case anyone stumbles upon this thread in the future, here is an example of an ipoke looper which works for me, gleaned from the delay example that comes with the external.

I should add that I found setting the buffer which ipoke records into to ‘dummy’ when not recording is also proving useful as a way of avoiding unwanted interpolation and/or having to continually re-record into the buffer.

In any case I am probably the only person who knows what I’m on about.

And if I do stumble upon this thread myself in >6 months – “Yes you’ve already done this!”

– Pasted Max Patch, click to expand. –
#196438
Feb 9, 2011 at 4:32pm

“And if I do stumble upon this thread myself in >6 months – “Yes you’ve already done this!”"

:-) happened to me

#196439

You must be logged in to reply to this topic.