vector size and sound distortion

Jan 22, 2010 at 12:10pm

vector size and sound distortion

Hi all,

i got this very irritating problem that ruins my patch: *_*
after a few minutes of playing* i got very disturbing sound distortion that goes away as soon as i change the vector size. The strange thing is that the problem get solved even if i just “reset” an identical amout of vector size.
Strange, no?

*i use midi to control garageband and have the sound back to Max though [adc] via soundflower.

#47943
Jan 22, 2010 at 1:11pm

post your patch

#172403
Jan 22, 2010 at 1:57pm

Did you try SoundFlower with 16 channels rather than 2?

#172404
Jan 23, 2010 at 2:41am

Are you using a MOTU interface?

#172405
Jan 24, 2010 at 10:36pm

well, i tried 16 ch soundflower and it did not work. i still have the messy distorted sound.
and not, unfortunately i’m not using a MOTU interface, but an M-audio firewire 410.
as for my patch… it seems that there’s an error in the site, because when i post it nothing happens. and i lost few times my message my message. btw, i start to think that it’s only because my cpu goes to up. but the patch is not too complicated, and, moreover, changing the vector size stops the problem.
mmm…

#172406
Jan 25, 2010 at 1:21am

Please check whether changing other dsp settings solves the problem, or just turning dsp on and off – My guess is that is has nothing to with vector sizes, but rather it is an issue with audio blow-up / cpu usage that is cleared when you restart audio (many audio objects reset themselves whenever audio is restarted).

Please try again repost your patch – I haven’t had any trouble posting patches using either firefox or safari. If you are still having trouble posting then decribe exactly how you are trying to do this and maybe someone can help.

It’s almost impossible to tell what the problem is without the patch at least. However – some questions that may be of some diagnositic use:

Do your levels go above 1. / -1 on your outputs from max? (ie. is the audio actually distorted within max, or does it just sound distorted?)

What is your CPU usage in the DSP window when this happens? Also what does activity monitor say?

What version of max?

Any third party msp externals?

Regards

Alex

#172407
Jan 26, 2010 at 12:10am

Alex, thanks much for you support: really unvaluable!
i try once again to repost my patch, it’s still a bit messy, but i tried to take off things which were unnecessary.

Briefly:
- it does not look like total levels are above 1.
- the dsp levels are not abot 20% or something like that on my white macbook 2.2 ghz core 2 duo 3 gb ram
- my max version is 5.1.2 (latest)
- well, yes, third part externals, but not using them (so, i thing it does not matter)

PS the patch on a new message

#172408
Jan 26, 2010 at 12:12am

no, i can’t post my patch.
it seems like a server problem, or something like that.
it doesn’t give me an error, it just does not post anything…
i don’t think it’s because it’s too long, ’cause it’s not that long..

#172409
Jan 26, 2010 at 12:27am

ok, it’s the only way to post my patch (tried safari and firefox as well)

http://rapidshare.com/files/341097598/patch.txt.html

hope the problem (alongside with mine, will be solved *_*)

#172410

You must be logged in to reply to this topic.