Forums > MIRA

Version mismatch

December 29, 2013 | 2:15 am

When mira connects to max (m4l in my case) I get a version mismatch error–max objects are out of date. It says I have version 1.0.7 installed, which is odd because I have installed 1.1.6 many times now. I have even tried reinstalling Max and the Mira ios app.

Is there a place where out-of-date mira externals could be hiding besides Max 6.1/packages/Mira? All files there are from Nov 8, 2013 so they should be from 1.1.6.

Mac OS 10.7.5
Max 6.1.6/Mira 1.1.6 package/latest Live Suite 9.1 (non-beta)
Ipad 2/ios 7.0.4/Mira app 1.1.6

I’m extremely frustrated. Any help resolving this is appreciated.


December 30, 2013 | 9:03 pm

@bitwise Ah, really sorry to hear about this frustrating situation. You definitely have a rogue, out of date mira.frame.mxo on your machine _somewhere_. Do you get the same out of date message when you open max directly (not through M4L)? As a guess, maybe M4L is opening a different version of Max?

Really sorry I can’t be more help, but if I were in your shoes I’d just Spotlight search for all mira.frame.mxo’s on my machine and make completely sure that only the one exists.

-S


December 31, 2013 | 11:29 am

I deleted or replaced old versions of mira.frame.mxo and all seems to be working now. Thanks for the help. I do find it a bit strange that max was grabbing the mxo from someplace other than Max 6.1/packages/Mira when creating a new patcher.


December 31, 2013 | 12:48 pm

Just noticed an error in the Max window complaining about multiple files in the search path. Now we’re getting somewhere. I think the problem comes from freezing the M4L devices which makes a copy of the externals, and then having those in my M4L device search path. Any suggestions how to avoid this? Where should I be saving my M4L devices by default? Thx.


Viewing 4 posts - 1 through 4 (of 4 total)