Forums > MaxMSP

Video Compressor Fail – Need Help Optimizing

October 30, 2010 | 12:00 am

So this compressor does the opposite of what I need it to as the video ends up bigger and frustratingly pixellated. There MUST be a better way to do this.

Any suggestions appreciated. Quality is important but it needs to be a reasonable file size.

Drag and drop a movie file on the drop zone, it’ll compress the movie and send it to a folder in Applications called myApp/library.

Thanks. :)

– Pasted Max Patch, click to expand. –

October 30, 2010 | 8:58 am

Its not something I’ve tried, but you may be better off using the ‘codec’ ‘codecquality’ and ‘acodec’ attributes combined with the ‘export’ message straight from jit.qt.movie rather than using jit.vcr. Have a look in the reference for jit.qt.movie.


October 30, 2010 | 5:04 pm

Oh, I feel silly now. I tried export but dismissed it as an option because I was worried the dialog would popup for each video and I needed to compress up to 50 videos at a time, all with the same settings. But now I realize, if the first video to be compressed is set properly, the next messages with a trailing 0 will supress the dialog. Perfect. Thanks so much for the response!


October 31, 2010 | 1:06 am

Rats, okay after testing this I think I’ve made a mistake. Because I’m exporting from different jit.qt.movie objects, the settings return to a default when sending each one an export message.

Is there any way to preserve the choices in the first dialog so that all subsequent movies are done at the same compression/settings? Like a message to alter the default settings?


October 31, 2010 | 9:21 am

Hi,

Not having looked at your patch yet, I guess you attempting to do this from whithin Max means that the videoes are generated on the fly somehow. Still, have you considered making a Compressor setting, and then use appkescript or a terminal command to compress them outside max? Might be that either the applescript object from tap.tools or the shell object might be of use.

Best,
Trond


October 31, 2010 | 9:27 am

If you select all qt.mov objects and then open the inspector and set the codec attribute in there does this fix your problem?


May 14, 2012 | 2:04 am

Though there are many Video Compressors, they either compress video in poor output quality or support few video formats.

This article just aims to introduce a powerful video compressor and a step by step guide on how to reduce the file size of various video with almost no loss of video quality at http://www.bigasoft.com/articles/how-to-compress-video-mkv-mpeg-avi-mp4-mov-wmv.html


January 5, 2013 | 8:34 am

The size of the video is dependent on four main factors: video dimensions, video quality, video length and compression type.
I assume you video files are mov file extension. you can try to convert them to flv with h.264 codec.
http://www.ilikemall.com/how-to/convert-flv-to-mov-mac.html
I have never had a problem compressing file with it.


May 30, 2013 | 2:04 am

though a old topic, but still helps and available


Viewing 9 posts - 1 through 9 (of 9 total)