Video volume randomly plays when I use load vid into vizzie

Dec 4, 2010 at 8:58am

Video volume randomly plays when I use load vid into vizzie

When I drag a video file into vizzie playr, the audio of the video just mysteriously starts playing, before I even press play. I can’t figure out how to turn it off… I just want the visual part from the video so I can control it with music from a separate song. Is anyone else having this problem of the audio just playing in the background and no way to turn it off? Or do u know how to stop the background audio of the video? Even when I pause the video, the background audio to the video keeps playing until I delete the playr module.

#53651
Dec 5, 2010 at 8:09am

you can set @vol 0. in jit.qt.movie. If you stop banging the movie it will continue to play the volume, just not refresh the visual frames. you need to tell it “stop” to really stop all of it (including the audio).

#192903
Dec 12, 2010 at 1:09am

I’m having this problem as well. Shouldn’t the default behavior for play/ stop on the vizzie playr stop and start both the video and the audio? There is noway for me to stop the audio once I load my video and I want video/audio to play and stop at the same time.

#192904
Dec 12, 2010 at 8:31pm

Hmmm. Looks like the issue is that not ALL tracks have their audio zeroed out. I’ll fix it for the next iteration.

#192905
Dec 19, 2010 at 9:12pm

Thanks! Vizzie is cool by the way. Makes it easy to get started.

#192906
Dec 27, 2010 at 11:52am

Setting the volume to zero in the jit.qt.movie object does stop audio, but only after a short time. This is due to the low priority processing of the qmetro object, I believe.

So what I did to resolve this, so that audio stopped at the approximately-exact same time as the video, is to extract the audio via the @soc method of jit.qt.movie, then with spigot~ drove the audio with the play/stop button of the vizzie playr, toggling a float num box across a few *~ into dac~

This stops the audio at the same time:

[attachment=149905,1599]

…all a bit painful, and now I’m hacking the vizzie playr into my own player with separate audio outs.

This is OK, but I’m unhappy to break away from the objects that will continue to be updated, on what will be a pretty frequent basis. I’ll be needing to add my hacks back into the branch if I want to continue using the latest vizzie version…

Any simpler methods?

Thanks!

Justin

Attachments:
  1. MaxMSPScreenSnapz001.jpg
#192907

You must be logged in to reply to this topic.