vst~ and MIDI control

Jul 8, 2006 at 9:46am

vst~ and MIDI control

hi all,

i know this topic has been discussed before, but i found an interesting fact that might solve the problem.

i’m using a vst plugin called Mobius (a real time looper based on Gibson’s EDP – zonemobius.com) and i’m trying to control it in real time with my FCB1010 MIDI footcontroller.
when i’m sending ANY MIDI message (i.e PC, CC, note etc.) to the plugin i get the error: “Program (X) outside effect’s range”. :-(

i tried to send a “midievent” (with the same MIDI number the controller sends) to the plugin and it worked just fine (!!), so i thought that the problem is with my MIDI interface/controller, but when i tried to use the plugin in other apps (Live, EnergyXT, Bidule) it worked fine.

it seems that Max is not sending the MIDI message “as is” or it sends it too fast/slow….

any ideas??

thnx
Udi

#26723
Jul 8, 2006 at 9:53am

the vst~ send midi controls (CC etc) in the range 0.-1., not 0-127

you have to scale the incoming values

__ as far i understand all hosts do the same, but probably the others
do the math themselves

best

kasper

Kasper T. Toeplitz
noise, composition, bass, computer

http://www.sleazeArt.com

#80199
Jul 8, 2006 at 10:01am

hi kasper,

thanx for the fast (!!) reply…

can you tell me how do i scale the incoming values?

Udi

#80200
Jul 8, 2006 at 10:09am

scale, zmap, @, lp.smampf ……. and probably many other ways

kasper

Kasper T. Toeplitz
noise, composition, bass, computer

http://www.sleazeArt.com

#80201
Jul 8, 2006 at 10:35am

not lp.smampf, but lp.scampf !!!

k

#80202
Jul 8, 2006 at 10:53am

thanx again!

but it still not working :-(

i patched “midiin” to “scale 0 127 0. 1.” and than to vst~ but i get the same error…. (with the new scaled values)
also tried it with “zmap” but it didn’t work…

thanx
Udi

#80203
Jul 8, 2006 at 11:06am

come on, read the help files and the reference manual !! it’s all there……

zmap works, you have to scale between zero and one (not minus one)
and give the name of the chosen parameter as message (or it’s number)

kind of gain 1. or gain $1 or 1 $1

kasper

#80204
Jul 8, 2006 at 11:50am

yeah, i’ll read the manual again…. :-)

actually i mistyped the minus here in the message (but not in my patch…).

hope i’ll work it out.

thanx a lot
Udi

#80205

You must be logged in to reply to this topic.