Forums > MaxMSP

vst~ fragload err -2804 HELP!

February 7, 2006 | 1:55 am

New to the forum, and to Max (what’s up?), but I would love some help with this issue. I’ve searched and I can’t seem to find an answer…

I’m trying to load the ESXP24 VST plugin distributed with Logic 6 from Emagic/Apple. When loaded into the vst~ object I get the error: "error: vst~ : can’t fragload EXSP24 VST, err -2804 <><><>"

I guess the -2804 error is some sort of conflict, though I don’t have another copy of the EXS VST instrument anywhere else on the computer.

Any ideas as to what this issue is an how to resolve it?

Has anyone ever used this vst instrument in Max and had some success?

Or, if worse comes to worse, does anyone know of a vst instrument sampler (or max sampler patch) that reads the .exs files I currently use?

Thanks for all your help!

–Jason


February 7, 2006 | 9:40 am

Never tried ESXP24 with the vst object…..but Kontakt works fine, and will read your *.esx files


February 7, 2006 | 12:03 pm

On around Feb 7, 2006, at 2:55, Jason said something like:
> I’ve searched and I can’t seem to find an answer…

It’s very surprising that a search on, say, "fragload interfacelib
2804" didn’t turn up anything. Note that in a Google search, if you
write -2804, Google will interpret that as "messages that do *not*
include the term 2804", which is not what you want.

The short answer: you’re trying to load a pre-OS X version of the VST
plugin. Replace it with a Carbon version.

– Peter

>
————– http://www.bek.no/~pcastine/Litter/ ————–
Peter Castine | ^
| Litter Power & Litter Bundle for Jitter
pcastine@gmx.net |
pcastine@bek.no | iCE: Sequencing, Recording, and Interface Building
4-15@kagi.com | for Max/MSP
| Extremely cool
| http://www.dspaudio.com
| http://www.dspaudio.com/software/software.html


Viewing 3 posts - 1 through 3 (of 3 total)