Forums > MaxMSP

VST fun and games

September 3, 2009 | 12:25 pm

hey folks
well, specifically Tiger folks running Max5
however, interested to here if this is an issue beyond OSX 10.4.11

right
any time i load a vst~ object i get general intermittent audio drop-outs, maybe once or twice a minute at most

this is only happening when i instantiate the vst~ object with a valid plugin name and only with regards to Max5

all is well otherwise and all is well in Max4.6
it makes no difference when i swap machines
it makes no difference when i turn off all wifi and routers
it makes no difference when i select a pro soundcard
it makes no difference what vst is loaded or whether it is opened or sounding

this is doing my nut in, because I can’t (along with c74 support) get to the bottom of it

it just needs one other person to observe this audio drop out to stop me going crazy here

if you run the patch attached it’ll be a bit dull and may take a few minutes to conclude – but it’d be mighty appreciated, i can fwd results to support

of note: it glitches on the audio output side, but if a quickrecord is also recording the tone it is *not* affecting the audio recorded, but which had sounded glitchy

we are talking about 50-100ms drops, very easy to hear
and *only* when vst~ is activated in Max5

anyone got any clues ?? pleaze ??

can you confirm this is a bug ??

best s

ps max file (not text) attached as i’m mailing from different m/c

CORRECTION: text to paste in below, file missing extension

max v2;
#N vpatcher 409 220 1057 861;
#P origin 40 0;
#P window setfont "Sans Serif" 14.;
#P window linecount 2;
#P comment 349 383 217 196622 Be patient – may take a minute or two before glitch;
#B color 13;
#P window linecount 1;
#P comment 6 46 445 196622 Sound interruptions in Max5 using vst~;
#B color 13;
#P comment 1 523 445 196622 MaxMSP 5.07 OSX Tiger 10.4.11 Intel Mac;
#B color 13;
#P window linecount 2;
#P comment 0 445 382 196622 All is Well in Max 4.6 / Sound only drops out in Max 5 (typical 50ms drop out);
#B color 13;
#P comment 2 383 335 196622 6) Audition tone with "UnMute VST" Selected (audio drops out once/twice per minute !!);
#B color 13;
#P comment 2 341 281 196622 5) Audition tone with "Mute" Selected (All is well);
#B color 13;
#P window linecount 1;
#P comment 311 94 131 196622 2) Select "Mute";
#B color 13;
#P window setfont "Sans Serif" 9.;
#P newex 218 210 56 196617 route text;
#P button 200 156 15 0;
#P message 218 157 86 196617 set FabFilter One;
#P newex 218 230 66 196617 prepend plug;
#P user textedit 218 183 357 202 98444 3 9 FabFilter One;
#P window setfont "Sans Serif" 14.;
#P comment 357 183 177 196622 1) Input Valid VST name;
#B color 13;
#P comment 29 133 111 196622 4) Set Volume;
#B color 13;
#P window setfont "Sans Serif" 9.;
#P message 227 267 30 196617 open;
#N vpatcher 20 74 418 383;
#P inlet 111 87 15 0;
#P window setfont "Sans Serif" 9.;
#P newex 69 157 36 196617 pass~;
#N vst~ loaduniqueid 0;
#P newobj 69 120 79 196617 vst~;
#P inlet 69 88 15 0;
#P fasten 3 0 1 0 116 111 74 111;
#P connect 0 0 1 0;
#P connect 1 0 2 0;
#P pop;
#P newobj 170 302 58 196617 p muteVST;
#P newex 170 266 38 196617 mute~;
#P user umenu 170 96 141 196647 1 64 112 1;
#X add UnMute VST;
#X add Mute;
#P user ezdac~ 5 211 49 244 0;
#P user gain~ 5 124 18 49 158 0 1.071519 7.94321 10.;
#P newex 5 99 61 196617 cycle~ 800;
#P window setfont "Sans Serif" 14.;
#P comment 5 243 124 196622 3) Enable DAC;
#B color 13;
#P window setfont "Sans Serif" 9.;
#P comment 259 267 100 196617 check vst loaded;
#P connect 2 0 3 0;
#P connect 3 0 4 0;
#P fasten 3 0 4 1 10 202 44 202;
#P connect 5 0 6 0;
#P connect 6 0 7 0;
#P fasten 14 0 11 0 205 177 223 177;
#P connect 13 0 11 0;
#P connect 11 0 15 0;
#P connect 15 0 12 0;
#P fasten 12 0 7 1 223 293 223 293;
#P fasten 8 0 7 1 232 293 223 293;
#P pop;


September 3, 2009 | 2:38 pm

My first suggestion would be to check your signal vector size, but there’s also the memory from long ago that there was a problem with airports around that time that played havoc with things. Try turning your airport off, if you have one.

Also, the use of mute~ is generally deprecated. It’s better to put things in a poly~ and turn ‘em on and off from there these days.


September 3, 2009 | 3:03 pm

hey thanks for posting

i’d already turned off airport and even downed the whole network to be safe

the signal vector size is 64, but i’ll experiment above

mute~ is there for the purposes of that test patch only !
it just allows an A/B comparison between normal and malfunctioning without any user patching – [ not sure it'd make sense in a poly in this instance but it's a good tip for other cases ]

this still doesn’t explain why there is only one circumstance reliably causing fault even if all else is constant

there are glitches for me using vst~ in max5 on tiger
no other triggers for this fault except that !!

it happens on both of my intel macs
i’ve emptied the vst folder etc etc

the fun and games continue

cheers


September 7, 2009 | 9:58 am

I have had another Tiger user confirm the same behaviour – so that’s three machines – it’d be very helpful if someone (anyone please) could give the patch a try ! FWIW increasing the sample vector size reduces the frequency of the glitches but does not resolve the issue.


September 8, 2009 | 8:34 pm

fyi, if you are experiencing this issue, please either wait for 5.0.8, or use the updated vst~ posted on a previous thread:

http://www.cycling74.com/forums/index.php?t=rview&th=39568&rid=5088

-Ben


September 8, 2009 | 8:51 pm

thumbs up – that does it !! Smile


Viewing 6 posts - 1 through 6 (of 6 total)