Forums > MaxMSP

VST Params Print Broken and Midi Mapping Is Broken For VST

March 14, 2012 | 3:54 am

So I have been taking this class for max. Using MAX 5 you can take a VST and hook up a params to the input and a print object to the output to get the VST param names to midi map them using a cltin and inputting your midi value for say a pot. This works great in Max 5. In Max 6 on the other hand when you hook up the Print object the params are not being outputed corretly and seem to have spaces in them giving the wrong parameter. Also the worst part is that andthing you map the params to with a mdid controller it will not work with any of the pots or faders. A good example is Vallahala echo I have set all params that are outputed to be mapped to 4 pots. When you turn all 4 pots it will only control the wet/dry knob even though the values have been set to correct midi numbers and params. I have tired 4 different midi controllers and the same result occurs. This is a serious bug in Max 6.


March 14, 2012 | 4:38 am

Without a patch to look at, we’d all just be playing 20 questions. You’ll get better answers if you provide better information.


March 15, 2012 | 12:09 am

I attached a patch example. You will have to add your own VST. You can see what I am talking about.

Thanks

Attachments:
  1. VSTSounds.maxpat

March 15, 2012 | 3:24 am

I’m not surprised that the patch you posted doesn’t work – unless the actual parameters in whatever plug-in you’ve loaded are actually called Control1, Control2, etc., they’ll never work.

I’m not sure how you came by these names because the example patch you send is completely missing the most obvious part – the bit where you send the message "params" to each of the vst~ objects when you load them and then the logic you’d use to collect the output from the third outlet of the vst~ object. Unless you know the *specific* name of a parameter that is specifically related to whatever the currently loaded plug-in is, you’ll be sending messages from now until the cows come home and nothing will happen.

Perhaps you might find these tutorials to be of some use to you.

http://cycling74.com/2005/04/14/investigations-part-1/
http://cycling74.com/2005/04/21/investigations-part-2/
http://cycling74.com/2005/04/28/investigations-part-3/

http://cycling74.com/2005/05/02/investigations-part-4/


March 15, 2012 | 3:43 am

That is very interesting. The way I had it setup in MAX 5 works fine. Just interesting that it does nto work in MAX 6. I appreciate the help and will read through the links you have provided. Thanks for the help.


March 22, 2012 | 8:06 am

Hello,

I have reviewed the documentation you provided and while helpful I still think this is an issue. I have attached the patch with the VST included as it is a free VST that you can use to see what I am talking about and this does not jsut happen for this VST it happens to all VST's that I have tried using, but works fine in MAX 5. I have also provided a screen shot showing the params are correct in my patch. For what I want to do the steps you provided seem to much for a simple task. You can test this in max 5 and it works. Then test this in 6 and change the setup of your midi controller to the values I have or to whatever you like for you own controller. You will see that this works in 5 and does not work in 6. If you could provide something that might have changed in the way this works in max 6 that would be great.

[attachment=189086,3577]

Attachments:
  1. Parameters.tiff

March 22, 2012 | 8:08 am

Here is the patch.

Attachments:
  1. VSTSounds.maxpat

March 22, 2012 | 8:10 am

Well it wont let me upload the VST but you can download it here for free:

http://valhalladsp.wordpress.com/category/frequency-shifter/


March 22, 2012 | 2:14 pm

OK — I can confirm that this is broken in Max 6. After removing everything other than essentials, I did two experiments

1) I tried using a different VST (Guitar Rig) to ensure that the problem was not due to a specific VST, got its parameter list but was unable to change any parameter

2) I then loaded the identical patcher under Max 5.1.9 and observed that it worked fine.

Something else of note: I normally just use parameter index and values rather than names and those work fine in both Max 5 and Max 6. So I normally display the data coming from the fourth outlet of the vst (that outlet shows parameter index and value whenever a parameter is changed, either by tweaking the VST GUI or by sending a new parameter in programmatically). Under Max 5, if I send one of the parameters by name (like vx6025 did), then I see the corresponding parameter index for that name.

However, if I do the exact same thing under Max 6, then the parameter index that I see is always 1, no matter what name I send in (including bogus names).

So there’s clearly something wrong with how incoming names are being processed in a vst~ under Max6


March 22, 2012 | 5:33 pm

I can confirm there is some weirdness with modulation using the parameter name in Max6

I’ll log it

Thanks

Andrew


March 22, 2012 | 7:16 pm

I wish my bugs were this easy to reproduce!


March 25, 2012 | 7:11 pm

Thanks so much


April 27, 2012 | 9:25 pm

I suppose the parameter control of VST didn’t work because in the parameter names are new spaces! If I cheque params of the VST:

In Max5 its named for example "Filter2Freq" (it works). And the same parameter in Max6 named "Filter 2 Freq". There are newly SPACES between! And it didn’t work with spaces!

Not all VSTs are affected of this space-phenomena.

Please help, it would be grate if common stuff like this will work


April 28, 2012 | 8:05 am

this not an excuse for malfunctions in the max6 object, but IMO one should generally avoid
using "highCut 0.77" for automation, "14 0.77" will do just fine.

the names can be helpful for displaying the parameters somewhere, but for parameters
it is enough to use the integer ID.

from the viewpoint of the VST interface i may say that named parameters never had another
purpoe than displaying those names to the user. a VST host program such as a max patch
should only work with IDs.


April 28, 2012 | 10:08 am

Hi Roman,
You right, with the ID it works fine.
So I have to move the slider in the VST-plugin to find out witch ID it have :)
Thanks for help!


April 28, 2012 | 10:50 am

I have been doing it that way myself forever. However, I have noticed that out of all my plugins, Kontakt doesnt send out those IDs, which is a real pain


April 28, 2012 | 7:31 pm

thats strange. is that why there were so many questions about kontakt in the forums?

but there are also some plug-ins with empty or nondescriptive paramater names, otoh, which
would be the first reason already to use numbers. :)


April 30, 2012 | 6:35 pm

The param names thing is fixed for 6.0.5 btw.

Cheers

-A


May 2, 2012 | 8:00 pm

"The param names thing is fixed for 6.0.5 btw."

:) and when it will be released?


Viewing 19 posts - 1 through 19 (of 19 total)