Forums > MaxMSP

[vst~] Reality Check

April 21, 2012 | 7:52 pm

Hi all-

Two questions about the [vst~] object on OSX:

1) If I load an AudioUnit, the parameter range is the range of the plugin parameter, unlike a loaded VST which Max scales to 0.->1., correct?

2) (see attached file) If I send the message "get 1" to get the value of the first parameter, I seem to be getting the value twice out the 4th-from-left outlet. Is this correct behavior, or am I doing something wrong? If correct, why?

Thanks, Charles

[attachment=191762,3752]

Attachments:
  1. dblval.png

April 22, 2012 | 5:55 am

i don´t know what juce or max6 are doing – but AU have (or can have) 64bit-resolution parameters, this could explain the double output somehow.

-110


April 23, 2012 | 2:41 pm

Thanks for your speculation, Roman.

So some AUs could have 32-bit parameters? If so, then perhaps I’ll be able to locate an AudioUnit that doesn’t produce this issue.

Best wishes, Charles


April 23, 2012 | 9:15 pm

Hi Charles,

I can’t reproduce any of this – params scale from 0.-1. and only output once when I get them.

Max 6.0.4 Mac 10.6.8

Which plug are you testing this with?

Cheers

Andrew


April 24, 2012 | 5:32 am

well it should not really create that double printing anyway, it is unexspected behaviour in any case.

cant reproduce it here.


April 24, 2012 | 2:17 pm

I don’t receive the double output from the get message, but I do when i send numbered parameters. I used different AUs to test with CamelCrusher, soundhacks +bubbler, amplitude3 etc… When using either Kontakt 4 or 5 the output spits out the previous value of the parameter then the new value.

Max 6.0.4 Mac 10.6.8

Rick

– Pasted Max Patch, click to expand. –

April 24, 2012 | 2:37 pm

ok I can see this in both VST and AU now.

Thanks for the patch. It seems like you get 2 messages, one for mouse down, and one for mouse up, when you click in the UI of a plug too.

We’ll have a look at it.

Cheers

Andrew


Viewing 7 posts - 1 through 7 (of 7 total)