Forums > MaxMSP

VST~ VERY high CPU usage!?

December 4, 2013 | 5:56 pm

Hi guys,

I am trying to build a VSTi host here. But the problem starts with the VST~ object itself …
When I just load a simple plugin, I already get high CPU values without even playing anything. As soon, as I play the CPU spikes with only one or two notes played causing glitches and crackles. This does not happen, when I load the Plugin standalone. I also does not happen, when I load a plogue bidule VST version in the vst~ object and host the VSTi itself in the plogue.
The problems appears with all plugins I have tried. Could be something really simple, but I cannot find the sollution …


December 4, 2013 | 8:59 pm

Assuming it is not an issue with Plogue generated plug-ins or the VST~ object itself, the most obvious thing(s) to check in Max are to be found in the Options/Audio Status Panel, particularly (but not limited to) the I/O and signal vector size settings. Smaller values will result in increasing demands on the processor.


December 5, 2013 | 4:38 am

Thanks! It was the signal vector size. When I set it to the same value as the I/O Vector size (which is defined by my asio sound card – I had 256), everything runs as expected!

On the Plogue Bidule thing you got me wrong: Kontakt hosted in a Bidule VST and that Bidule VST run in Max DIDN’T cause a glitch! But I would rather run the VSTs directly in Max, in order to be able to open the plugin interface with a simple command without having to click it in Bidule again. But since finding out about signal vector size it workls now.
What does that parameter mean by the way. Couldn’t find it in the manual …


December 5, 2013 | 7:27 am

There is somewhat of an explanation of the Audio settings (for Max 5 but mostly still relevant) on this page – : http://cycling74.com/docs/max5/tutorials/msp-tut/mspaudioio.html


December 5, 2013 | 9:49 am

this is still not right.

a vector size of 32 is what nuendo or protools use, it is the default size for their plug-ins interfaces.

so you could think that at the same vectorsize a plug-in in maxmsp will use about the same processing power as on in other apps.

-110


December 7, 2013 | 3:57 am

It’s ok now! I just tried the highest value first, but a value of 32, as you described also yields acceptable CPU performance.


Viewing 6 posts - 1 through 6 (of 6 total)