Forums > MaxMSP

wave~ is noisy when changing the start or end loop positions

May 2, 2013 | 2:56 pm

I’m afraid everything is in the title…
Open wave~‘s helpfile, set the period of the phasor to 2200 (step 4 in the helpfile) to have Anton played more or less at the right speed.
Then start to change the start or end position of the loop, you’ll get nice clicks. Sending signals (even smoothed) doesn’t help.

This happens under OSX, with Max5, Max6 and Max6.1!!

Please don’t tell me I should use groove~! I just wanted to build a palindrome looper…


May 2, 2013 | 4:55 pm

In my own experience (confirmed under Max 6 with students last week), play~is much more reliable (please note I haven’t mentioned groove~).


May 2, 2013 | 5:57 pm

Bonsoir Roald,

Merci pour ta proposition but…
I prefer a phasor driven object.
And speaking about play~, I invite you to try to new loop feature, especially the interpolation time setting. I don’t know if it’s suppose to dramaticalle enhance the quality of the loop (like groove~‘s resample is supposed to do), but it seems curious to me!

Anyway, I think I will build my palimdrome looper with 2 grooves…

Sorry, I had a very bad day using Max today!


May 4, 2013 | 8:30 pm

You can use play with a phasor, like in the example below.
If you need durations I suggest gen ( > duration, history, accum)
Let me know if you need an example of that.

– Pasted Max Patch, click to expand. –

May 6, 2013 | 8:48 am

@ullrich. Thanks for your comment. In Max5 your patch will unfortunately only work nicely with samples shorter than ±6 minutes. You’ll have to use hr.play~ for longer samples.
My topic was more a complain about wave~ and as nobody from c74 commented my post, I’ll soon introduce an official bug report!


Viewing 5 posts - 1 through 5 (of 5 total)