waveform~ and pattrstorage strangeness

Jul 27, 2007 at 7:17pm

waveform~ and pattrstorage strangeness

dear all what am i missing here…
thanks a lot

max v2;
#N vpatcher 10 59 699 455;
#P toggle 304 299 15 0;
#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P message 304 320 78 196617 changemode $1;
#P message 211 297 78 196617 storagewindow;
#P message 167 308 14 196617 3;
#P message 167 283 14 196617 2;
#P message 167 255 14 196617 1;
#P message 105 311 43 196617 store 3;
#P message 105 283 43 196617 store 2;
#P message 105 253 43 196617 store 1;
#P newex 205 341 142 196617 pattrstorage a @savemode 0;
#X client_rect 0 0 640 240;
#X storage_rect 0 0 640 240;
#P objectname a;
#P newex 355 27 51 196617 pattr end;
#X prestore 1 0 1750;
#P objectname end;
#P newex 261 52 59 196617 pattr start;
#X prestore 1 0 1670;
#P objectname start;
#P message 403 68 39 196617 set $1;
#P message 337 68 39 196617 set $1;
#P newex 165 36 48 196617 loadbang;
#P number 403 89 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P objectname number[1];
#P number 337 89 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P objectname number;
#P message 165 66 37 196617 set bu;
#P newex 76 36 84 196617 buffer~ bu 2000;
#P user waveform~ 205 124 274 101 3 9;
#W mode select;
#W mouseoutput continuous;
#W unit ms;
#W grid 1000.;
#W ticks 0;
#W labels 1;
#W vlabels 0;
#W vticks 1;
#W bpm 120. 4.;
#W frgb 33 0 0;
#W brgb 60 178 173;
#W rgb2 0 95 255;
#W rgb3 0 0 0;
#W rgb4 0 0 0;
#W rgb5 190 137 255;
#W rgb6 100 100 100;
#W rgb7 100 100 100;
#P window linecount 6;
#P comment 89 135 100 196617 problem: try store different selections and recall them , i get strange behaviour and inaccuracies;
#P connect 6 0 3 0;
#P connect 3 0 1 0;
#P connect 19 0 11 0;
#P hidden connect 12 0 11 0;
#P hidden connect 13 0 11 0;
#P hidden connect 14 0 11 0;
#P hidden connect 15 0 11 0;
#P hidden connect 16 0 11 0;
#P hidden connect 17 0 11 0;
#P connect 18 0 11 0;
#P fasten 20 0 19 0 309 319;
#P fasten 1 2 7 0 314 234 514 234 514 50 342 50;
#P connect 9 1 4 0;
#P connect 7 0 4 0;
#P connect 4 0 1 2;
#P fasten 1 3 8 0 366 230 488 230 488 57 408 57;
#P connect 10 1 5 0;
#P connect 8 0 5 0;
#P connect 5 0 1 3;
#P pop;

#33064
Jul 27, 2007 at 7:33pm

On 27 juil. 07, at 21:17, mic wrote:

> dear all what am i missing here…

priority maybe? Otherwise, more description will help to figure out
what your problem is.

Cheers,
ej

#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P message 383 285 151 196617 priority end 2 , priority start 1;
#P toggle 304 299 15 0;
#P message 304 320 78 196617 changemode $1;
#P message 211 297 78 196617 storagewindow;
#P message 167 308 14 196617 3;
#P message 167 283 14 196617 2;
#P message 167 255 14 196617 1;
#P message 105 311 43 196617 store 3;
#P message 105 283 43 196617 store 2;
#P message 105 253 43 196617 store 1;
#P newex 205 341 142 196617 pattrstorage a @savemode 0;
#X priority start 1;
#X priority end 2;
#X client_rect 0 0 640 240;
#X storage_rect 0 0 640 240;
#P objectname a;
#P newex 355 27 51 196617 pattr end;
#X prestore 1 0 1748;
#P objectname end;
#P newex 261 52 59 196617 pattr start;
#X prestore 1 0 1668;
#P objectname start;
#P message 403 68 39 196617 set $1;
#P message 337 68 39 196617 set $1;
#P newex 165 36 48 196617 loadbang;
#P number 403 89 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P objectname number[1];
#P number 337 89 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P objectname number;
#P message 165 66 37 196617 set bu;
#P newex 76 36 84 196617 buffer~ bu 2000;
#P user waveform~ 205 124 274 101 3 9;
#W mode select;
#W mouseoutput continuous;
#W unit ms;
#W grid 1000.;
#W ticks 0;
#W labels 1;
#W vlabels 0;
#W vticks 1;
#W bpm 120. 4.;
#W frgb 33 0 0;
#W brgb 60 178 173;
#W rgb2 0 95 255;
#W rgb3 0 0 0;
#W rgb4 0 0 0;
#W rgb5 190 137 255;
#W rgb6 100 100 100;
#W rgb7 100 100 100;
#P window linecount 6;
#P comment 89 135 100 196617 problem: try store different selections
and recall them , i get strange behaviour and inaccuracies;
#P connect 21 0 11 0;
#P connect 5 0 1 3;
#P connect 8 0 5 0;
#P connect 10 1 5 0;
#P fasten 1 3 8 0 366 230 488 230 488 57 408 57;
#P connect 4 0 1 2;
#P connect 7 0 4 0;
#P connect 9 1 4 0;
#P fasten 1 2 7 0 314 234 514 234 514 50 342 50;
#P fasten 20 0 19 0 309 319;
#P connect 18 0 11 0;
#P hidden connect 17 0 11 0;
#P hidden connect 16 0 11 0;
#P hidden connect 15 0 11 0;
#P hidden connect 14 0 11 0;
#P hidden connect 13 0 11 0;
#P hidden connect 12 0 11 0;
#P connect 19 0 11 0;
#P connect 3 0 1 0;
#P connect 6 0 3 0;
#P window clipboard copycount 22;

#109590
Jul 27, 2007 at 8:14pm

At 9:17 PM +0200 7/27/07, mic wrote:
>dear all what am i missing here…

It seems like waveform is not happy with the order that things are being restored, use a priority message to pattrstorage make start come out before end

-C


Chris Muir | “There are many futures and only one status quo.
cbm@well.com | This is why conservatives mostly agree,
http://www.xfade.com | and radicals always argue.” – Brian Eno

#109591
Jul 27, 2007 at 10:26pm

:-))!!
thanks a lot

#109592

You must be logged in to reply to this topic.