wclose -> thispatcher no longer crashes

Oct 2, 2008 at 10:02am

wclose -> thispatcher no longer crashes

hi list !

when sending wclose to thispatcher, i get an error saying “method wclose
called on invalid object”.

why ?

cheers

g

#40119
Oct 2, 2008 at 10:41am

I think this was fixed in the new version…

http://www.cycling74.com/version/version_5_0_5.html

#141672
Oct 2, 2008 at 11:32am

nop, i use the new version… this message wasn’t there in the previous one.

g

2008/10/2 mHatsys

>
> I think this was fixed in the new version…
>
> http://www.cycling74.com/version/version_5_0_5.html
>
>
>
>

#141673
Oct 3, 2008 at 7:59am

Guillaume Evrard schrieb:
> when sending wclose to thispatcher, i get an error saying “method wclose
> called on invalid object”.

can’t reproduce, works fine here on PPC OS X 10.4.11 and 5.0.5.
Does your window actually close? If so, I’d suspect you send that
message to some other object as well somewhere in your patch…

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com

#141674
Oct 3, 2008 at 9:31am

yes my window closes. i tested with a simple patch containing (thispatcher)
and the close message.
i just find this message strange.

g

2008/10/3 Stefan Tiedje

> Guillaume Evrard schrieb:
>
>> when sending wclose to thispatcher, i get an error saying “method wclose
>> called on invalid object”.
>>
>
> can’t reproduce, works fine here on PPC OS X 10.4.11 and 5.0.5.
> Does your window actually close? If so, I’d suspect you send that message
> to some other object as well somewhere in your patch…
>
> Stefan
>
> –
> Stefan Tiedje————x——-
> –_____———–|————–
> –(_|_ —-|—–|—–()——-
> — _|_)—-|—–()————–
> ———-()——–www.ccmix.com
>
>
>

#141675
Oct 3, 2008 at 10:01am

Confirmed, happens also with poly.

seems to me you cannot send a wclose message without its “target” anymore.
wclose works fine if it finds a true corresponding window open.
If not it gives this “error”

although everything works from a practical point of view.

Problem introduced with version 5.0.5, not present before.

Macbook Intel system 10.4.11
Max 5.0.5

ciaoo

#141676
Oct 3, 2008 at 10:15am

i reinstalled 5.0.5
i no longer have this message with thispatcher.

g

2008/10/3 Jabbo

>
> Confirmed, happens also with poly.
>
> seems to me you cannot send a wclose message without its “target” anymore.
> wclose works fine if it finds a true corresponding window open.
> If not it gives this “error”
>
> although everything works from a practical point of view.
>
>
>
> Problem introduced with version 5.0.5, not present before.
>
>
>
> Macbook Intel system 10.4.11
> Max 5.0.5
>
>
>
> ciaoo
> –
> http://www.lan-muzic.com
> http://www.myspace.com/jacopocarreras
>

#141677
Oct 7, 2008 at 9:23am

reinstalling doesn’t solve this ‘strangeness’ on my computer…

matteo

osx 10.5.5
MaxMsp 5.0.5
Jitter 1.7

#141678
Oct 16, 2008 at 7:55am

Any news on this?

I keep on receiving thsi error message in combination with poly, or thispatcher.

From the poly help documentation:

“When used without the number argument, wclose will close the patcher window with the highest index number”

I would expect that if no window has been opened yet the wclose message would just do nothing, but if i send a wclose 0 (so to close all windows) until the latest update it worked, now i get this error message.

I won

#141679
Oct 16, 2008 at 9:48pm

this error will be fixed for the next incremental.

-Ben

#141680

You must be logged in to reply to this topic.