Weird 3D effects

Aug 29, 2007 at 1:18am

Weird 3D effects

Example Screenshots
http://rhythmicdesign.com/images/VMPStill1.tiff
http://rhythmicdesign.com/images/VMPStill2.tiff

http://rhythmicdesign.com/images/VMPStill3.tiff

It may not be very clear, but if you look in the images you might notice a certain zig-zag triangular artifact. It seems to only occur on 3D object primitives (ie, not planes and circles) when the object is somewhat transparent.

I’m sure this is a OpenGL rendering issue and not specifically a Jitter problem, but I’m not sure if
1 – can this type of rendering be changed or improved somehow?
2 – what options are available in Jitter to do so? Is this a jit.gl.render config issue?

Any thoughts, helps, suggestions would be appreciated.

Thanks!
greg

[img]index.php?t=getfile&id=818&private=0[/img]

#33452
Aug 29, 2007 at 1:51am

it looks to me as though you have @blend_enable 1, @depth_enable 1? try turning off depth enabling.

pelado

#111485
Aug 29, 2007 at 6:44am

Greg Thompson skrev:
> Example Screenshots
> http://rhythmicdesign.com/images/VMPStill1.tiff
> http://rhythmicdesign.com/images/VMPStill2.tiff
> http://rhythmicdesign.com/images/VMPStill3.tiff
>
> It may not be very clear, but if you look in the images you might notice a certain zig-zag triangular artifact. It seems to only occur on 3D object primitives (ie, not planes and circles) when the object is somewhat transparent.
>
> I’m sure this is a OpenGL rendering issue and not specifically a Jitter problem, but I’m not sure if
> 1 – can this type of rendering be changed or improved somehow?
> 2 – what options are available in Jitter to do so? Is this a jit.gl.render config issue?
Hi Greg,
first of all I’d like to say I’m glad I’m not the only one that was
stumped by this!
I have wondered this before and got the general impression from the
response that “that’s the way the object works”.
There is a simple explanation, however – try the patch below for further
confusion.

Andreas.

#P window setfont “Sans Serif” 9.;
#P window linecount 9;
#P comment 232 303 123 9109513 Rotate the objects to see the difference.
Purple object has visible planes inside it , grey object doesn’t. The
difference is because of the different calls the jitter objects make to
openGL , but I’ll leave that question to the pros…;
#P window linecount 1;
#P comment 370 210 123 9109513 – doesn’t have the problem;
#P newex 183 185 82 9109513 jit.gl.handle testor;
#P window linecount 2;
#P newex 183 232 352 9109513 jit.gl.plato testor @blend_enable 1
@blend_mode 6 1 @color 1. 1. 1. 0.3 @position 1. 1. -4. @shape cube @dim
10 10 @rotatexyz 45 45 0 @lighting_enable 1;
#P number 308 56 35 9 0 0 0 139 0 0 0 221 221 221 222 222 222 0 0 0;
#P window linecount 1;
#P message 308 80 49 9109513 dim $1 $1;
#P newex 175 64 82 9109513 jit.gl.handle testor;
#P toggle 30 40 15 0;
#P newex 30 100 53 9109513 t b b erase;
#P newex 30 70 50 9109513 qmetro 10;
#P newex 12 242 164 9109513 jit.window testor @floating 1 @fsaa 1;
#P newex 30 130 81 9109513 jit.gl.render testor;
#P window linecount 2;
#P newex 175 123 367 9109513 jit.gl.gridshape testor @blend_enable 1
@blend_mode 6 1 @color 1. 0. 1. 0.3 @position 0. -1. -4. @shape cube
@dim 10 10 @rotatexyz 45 45 0 @lighting_enable 1;
#P window linecount 1;
#P comment 379 93 100 9109513 – has the problem;
#P window linecount 9;
#P comment 372 304 79 9109513 jit.gl.plato draws the 4*6 (?) vertices
directly to OpenGL , as far as I remember , skipping the “connected
grid-part.”;
#P window linecount 10;
#P comment 110 303 100 9109513 “The jit.gl.gridshape object creates one
of several simple shapes laid out on a connected grid (sphere” , torus
, cylinder , opencyclinder , cube , opencube , plane , circle);
#B color 15;
#P connect 10 0 3 0;
#P connect 9 0 3 0;
#P connect 13 0 12 0;
#P connect 11 0 10 0;
#P connect 7 2 4 0;
#P connect 7 0 4 0;
#P connect 6 0 7 0;
#P connect 8 0 6 0;
#P window clipboard copycount 16;

#111486
Aug 30, 2007 at 5:14pm

I tried switching these on the jit.gl.render object … no change.

I’m mainly using jit.gl.mesh to create the shapes … I have also tried disabling depth_enable .. no change.

If I disable blend_enable, I can’t achieve any transparency – so I can’t really reproduce the effect.

greg

#111487

You must be logged in to reply to this topic.