Forums > Max For Live

what's taking so long?

June 26, 2010 | 8:21 pm

Hello all,

Max and especially Max for Live have been taking a very long time to get started on launch. I did a little bit of timing…

Max for Live (without Max open first) took 2:38 to boot! With Max already running this was reduced to a speedy 1:12.
The Max for Live editor (opening for the first time after launch) took an additional 1:06 with Max not running, but was practically instantaneous with Max already open (which makes sense since it’s more or less the same as starting a new project in Max).
Max itself is also slow, taking 55 seconds to boot.

Is there anything I might do to speed things up? With Max for Live especially, the long wait just makes the software less approachable, as I like a speedy workflow.

I’m on Snow Leopard on an Intel MacBook running the latest versions of Ableton and Max. Any suggestions are gratefully appreciated.

Truly yours,
Jay


June 26, 2010 | 8:55 pm

Try moving your preferences out or deleting them and rebuilding your database cache – just restart Max.

Preferences are in

~/Library/Preferences/Max 5 Preferences Folder

-A


June 26, 2010 | 11:55 pm

Andrew,

I tried this with no significant improvement. M4L still took 2:25 and Max itself took 1:00.

Any other reasons it would be taking so long?


June 27, 2010 | 5:04 am

Did you quit, then delete the prefs, then restart?

If so and it’s still bad send us a note in support and we’ll try and help figure it out.

-A


June 27, 2010 | 8:16 am

hi,
can you keep the forum up-to-date ?
I have the same problem: the first start of M4L takes looong.
even after installing 2GB more RAM.

MacBook-Pro 2.5 Intel Gore 2 Duo.
MACOSX- 10.5.8.
4GB RAM

thanks!
bd


June 28, 2010 | 7:46 pm

Hi bd,

Support suggested I delete Max and reinstall. First I deleted the prefs folder at ~/Library/Preferences/Max 5 Preferences Folder, then the Applications/Max 5 folder (anything I had added – externals and the like – I moved onto the desktop to put back later). I downloaded and reinstalled from the cycling74 site, then put all my extras back in place, now Max and Max for Live are opening very fast.

Hope this helps for you too.


June 28, 2010 | 7:49 pm

One thought I just had…

I noticed that my file preferences are reset (as one would expect with reinstallation). It’s possible that Max might somehow go through your file paths when it’s first launched, and that this might contribute to the long startup time. Just an idea, not sure if it’s true, might be worth a try though.


June 28, 2010 | 10:50 pm

I remember reading somewhere on the forum about things slowing down due to the number of files/levels in the search path (maybe in relation to included VSTS although I am not too sure right now). Not having ridiculous numbers of files in the seach path will help with load times. Perhaps try to keep your abstractions and external objects folders organised. You can always add certain extras dynamically. I find grouping project files in one folder, rather than adding them to the search path helps. It doesn’t have an effect on startup but the files will be recognised by other patches at the same level.

lh


June 29, 2010 | 8:36 pm

hi°,

thanks !

"Support suggested I delete Max and reinstall. First I deleted the prefs folder at ~/Library/Preferences/Max 5 Preferences Folder, then the Applications/Max 5 folder (anything I had added – externals and the like – I moved onto the desktop to put back later). I downloaded and reinstalled from the cycling74 site, then put all my extras back in place, now Max and Max for Live are opening very fast."

I did so.
got a very fast start – but after putting back my EEEEEEEEEEEEEEXTRAS – it is slow like before.
I will try now different set-ups = summer cleaning.

best wishes,
bd


Viewing 9 posts - 1 through 9 (of 9 total)