Forums > MaxMSP

Why can't I see any change in number~ in pfft~ subpatch ?

June 28, 2006 | 12:29 am

I am trying some example patches of cycling74 that deal with FFT. Everything works fine except that when I connect number~ to the output of framedelta~, phaserwrap~, frameaccum~, and the rightmost output of fftin~, the number~ box never changes.

I turned on the dac~, and all the patches function OK except this little thing. Is it normal ? Why ?

Please help explain a little bit.
Thank you very much.


June 28, 2006 | 1:20 am

As a workaround, have you tried using fftout~ with the ‘nofft’ message? It should allow you to connect your number~ object outside of fft-world.


June 28, 2006 | 10:47 am

Hiya,

OK – This is (usually) normal behaviour for pfft~ because:

number~ displays the first value in each signal vector.

in a pfft~ each signal vector is equivalent to one frame of the fft.

the first value in the signal vector will hence be the value from bin zero (the DC bin)

Normally your audio input will have no DC content and even if it does the phase content will be zero (DC has no phase) so you can expect zero values in this bin.

If you want to view values from other bins (much much more useful) use capture~ or snapshot~ connected to a float numberbox(the later from what i remember allows you to select an offset from the beginning of a signal vector – and hence the bin you wish to view)

Hope this helps explain things!
Alex


June 28, 2006 | 4:09 pm

Cheng Chien-Wen wrote:
> I turned on the dac~, and all the patches function OK except this
> little thing. Is it normal ? Why ?

It is normal, as it would only show the last value of a signal vector,
and thats always the same in this case. Use capture~ to see more…

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com


Viewing 4 posts - 1 through 4 (of 4 total)