why is mpeg video playback so slow and cpu intensive?

Aug 16, 2007 at 9:51am

why is mpeg video playback so slow and cpu intensive?

hi all

there’s sometihing I don’t understand about how jitter handles video playback with quicktime. I’m on WinXP.
when I play a mpeg1 movie without jitter simply with the desktop quicktime player it runs absolutely smooth and with 15% average CPU load.
when I start the same mpeg1 file in jitter with jit.qt.movie the CPU load varies between 30 and 80% and the video stutters with framerates between 3 and 5 fps!!
Using photojpg instead of mpeg1 works better but why?! And it’s still not 25fps.
When I compare mpeg1 with pjpeg in the Quicktime desktop player, mpeg1 always runs smoother and with 25fps.

thanks
secco

#33284
Aug 16, 2007 at 9:31pm

my suspicion is that this happens because quicktime for windows is
such a shitty mpeg-1 playback engine.

On Aug 16, 2007, at 5:51 AM, secco wrote:

>
> hi all
>
> there’s sometihing I don’t understand about how jitter handles
> video playback with quicktime. I’m on WinXP.
> when I play a mpeg1 movie without jitter simply with the desktop
> quicktime player it runs absolutely smooth and with 15% average CPU
> load.
> when I start the same mpeg1 file in jitter with jit.qt.movie the
> CPU load varies between 30 and 80% and the video stutters with
> framerates between 3 and 5 fps!!
> Using photojpg instead of mpeg1 works better but why?! And it’s
> still not 25fps.
> When I compare mpeg1 with pjpeg in the Quicktime desktop player,
> mpeg1 always runs smoother and with 25fps.
>
> thanks
> secco
>

#110680

You must be logged in to reply to this topic.