will standalone built on win7 work on win xp?

Sep 17, 2011 at 11:51am

will standalone built on win7 work on win xp?

hello,

the title alreay spells it out. i am a mac user but have to built something crossplatform, which i usually do from a virtual machine.
now, that thing died and having to reinstall, i am pondering my options: i want the windows standalones to be as compatible as possible and don´t know, if a win7 build will be working on xp.
any insights?

thanks in advance
hans

#58035
Sep 18, 2011 at 1:37am

A great question and one which I haven’t tried yet. My thought was that they would be fine. Anyone try this out?

I don’t have access to a Win7 with Max, but I could try a standalone made on XP and see if it works on Win7. I don’t have a way to test the opposite though. Would be nice to know.

#208448
Sep 18, 2011 at 3:51pm

here is a standalone built on xp, if you could throw that on a win7 machine, i´d be thankful!
http://www.hans-w-koch.net/download/more&more_win.zip
when you launch it, it opens a small black window. hit the spacebar and it sets in motion like on this video here:
http://www.hans-w-koch.org/video/benchmark.html
lower the volume before, if you are using headphones or late at night…
you can stop it with either spacebar again or holding the “k” key until it crahses.

i´d be also very interested in the opposite though: win7 standalone on xp. any takers?
thanks
hans

#208449
Sep 18, 2011 at 4:00pm

Here’s one. Give me 15 – 20 minutes and we’ll know. I run Win7 Professional which also gives me access to Windows XP mode (basically running XP on MS’ Virtual PC).

Never played with standalones before, now would be a good time. I once build a M4L tone generator, converted that to a full Max patch and I’ll see what happens if I make a standalone out of it and try using it on Win XP.

#208450
Sep 18, 2011 at 4:09pm

Works without problems. Makes perfect sense too considering that although we call this a standalone its not really fully stand alone so to speak. After all; you end up with a directory containing not only the executable but also a bunch of dll files (libraries) which go with it. Without those DLL’s the program won’t work.

As such its only logical that this will also work on XP, think you might even be able to use this stuff on ’98 as well. But alas; as long as you copy the entire directory it works like a charm.

Edit:

PS: When looking at the Max runtime Window I do pick up some error messages:

– sysmidi: bad arguments for message “portabbrev”
– sysmidi: bad arguments for message “portoffset”
– sysmidi: bad arguments for message “portenable”

I’m pretty sure that this is triggered because I don’t have any midi devices available in that VM but figured I’d mention it anyway.

Hope this helps!

#208451
Sep 18, 2011 at 4:48pm

thank you, shelluser.
i know, it seems logical, that it would work, but then there is a lot in computers, which seems logical and then doesn´t work, especially for a mac user looking at windows (and -i am pretty sure- vice versa).
so i am grateful for your confirmation!

the error messages sometimes also happen when building in xp – also missing .svg files and such. nothing severe.

hans

#208452
Sep 18, 2011 at 5:32pm

I’ve built numerous standalones on XP and the seem to always work on both Vista and Windows 7 without any problems. I haven’t gone the other way around, though.

#208453
Sep 22, 2011 at 11:05am

Regarding Win 98: I wouldn’t bet on it. When the first Windows versions of Max/MSP were released, the official minimum config was XP. Some people tried installing on 2000, occasionally it worked but mostly it didn’t. After a while Cycling ’74 got so sick and tired of support questions about why Max wasn’t working under 2000, they modified their installers to refuse to install on anything earlier than XP.

I’ve been cross-building Windows standalones between XP/Vista/7 for a while and there have not been issues (other than the basic issues that the three OS’s behave differently on things like read/write permissions to certain directories, yadayadayada).

#208454
Sep 22, 2011 at 12:54pm

Peter’s last point about read/write permissions is important – this has caught me off guard once, when I was writing to somewhere that was OK on XP, but not on 7.

Dan

#208455

You must be logged in to reply to this topic.