window blink after window messages

Oct 14, 2009 at 4:17pm

window blink after window messages

In a patch that I build into a standalone, I send [window flags nogrow] and [window flags nozoom] messages to a thispatcher object right from the first loadbang message. This causes the patch (and the resulting standalone) to make the window “blink” (redraw) in a very noticeable way.

Is there any way to avoid having my end users see this redraw? Do I make the patcher’s opening location off-screen somehow, send the window flags messages, and then move the window back on screen or something? Or some other way?

Any help greatly appreciated, this is a long standing nitpick of mine.

Thanks,
Dan

#45866
Oct 15, 2009 at 4:44am

you might try “savewindow 1″ to thispatcher, make your changes, then load the patch again without the loadbang window messages. It should recall the window flag states on reload and avoid the blink, but I haven’t tested it.

#165315
Oct 15, 2009 at 8:40pm

Great idea Seejay, I had never noticed that message to thispatcher!

It works perfectly, thanks — one less Max nitpick!!

Dan

#165316
Jul 31, 2013 at 3:08pm

I am not sure I understand where you put the savewindow 1. I, too, have the same issue where the window open and closes numerous times at the start of the executable file and I understand why this is occurring.

Attached is an image of my [loadbang] call to [thispatcher].

So I researched if it was possible to set settings before the [patcher] is fully loaded.
and I found the [standalone] object, and the preffilename attribute, thinking that this may be a route to take for the fix. I am not seeing any tutorial or example on how to set up the external file.

Any suggestions?

Attachments:
  1. loadbang_image
#257725
Aug 13, 2013 at 8:26am

I found my solution. I used [loadmess] instead of [loadbang] when loading my window flags. [loadmess] outputs the message when the file is opened whereas [loadbang] outputs when the patcher is loaded.

[loadmess]
|
[message]
|
[thispatcher]

#258773

You must be logged in to reply to this topic.