Window Settings in a Patcher

Aug 6, 2008 at 4:58pm

Window Settings in a Patcher

Hello all,

Like most of my questions, this is probably really straightforward, but I can’t seem to find a way to do this…

I have a Max patch that has several patches (‘p’ objects) within in. Some of these are editable, and I’ve used ‘pcontrol’ with an ‘open’ message to allow me to open these up.

However, every time they open, the window size and view are not what I’d like them to be. Is there a way to customize the view and windowsize when opening a ‘p’?

Thanks in advance,
Joel

#39172
Aug 6, 2008 at 5:31pm

check the

subpatcher in the helpfile for the

object, i’m pretty sure it’s got what you need

#137539
Aug 6, 2008 at 5:57pm

Hi.
You can also arrange them as you want and then save the main patch.
Their positions options (as well as their opened/closed state) will be
saved with main patch.

Ciao

#137540
Aug 6, 2008 at 6:00pm

Quote: RabidRaja wrote on Wed, 06 August 2008 13:31
—————————————————-
> check the

subpatcher in the helpfile for the

object, i’m pretty sure it’s got what you need
—————————————————-

Hi there,

Thanks for this, I’ll take a close look!

Cheers,
Joel

#137541
Aug 6, 2008 at 6:02pm

Quote: gusanomaxlist wrote on Wed, 06 August 2008 13:57
—————————————————-
> Hi.
> You can also arrange them as you want and then save the main patch.
> Their positions options (as well as their opened/closed state) will be
> saved with main patch.
>
> Ciao
>
—————————————————-

Hola,

This is what I thought as well, but it definitely isn’t working that way. I think it was like this in MAX 4, but it’s not getting the same results in MAX 5.

Regardless, thank you for responding…

Cheers,
Joel

#137542
Aug 6, 2008 at 6:16pm

joelsquare wrote:
> This is what I thought as well, but it definitely isn’t working that
> way. I think it was like this in MAX 4, but it’s not getting the same
> results in MAX 5.

It does save the patchers windows positions here (osx, 5.04).

Ciao

#137543
Aug 6, 2008 at 6:19pm

Hmmm… that is odd… is there something that I could be doing wrong? It definitely isn’t doing that here. I wish it would. :(

Are you in Presentation Mode or are you saving while locked/unlocked?

Cheers,
Joel

#137544
Aug 6, 2008 at 6:19pm

P.S.

I’m also on OSX, vers 5.04

#137545
Aug 6, 2008 at 6:26pm

This is weird indeed.
It works for me regardless of presentation mode or locked/unlocked state of the patch…

Ciao

#137546
Aug 7, 2008 at 3:18pm

Weird… I wonder what about my set up prevents that (is there a bug)? I expected the behaviour you described, but it definitely isn’t happening here.

Thanks so much for weighing in though…

Cheers,
Joel

#137547

You must be logged in to reply to this topic.