Forums > Jitter

windows luaODE?

April 18, 2007 | 7:46 pm

hello wes,

jit.gl.lua rocks.

any plan on getting the lua ode.so module compiled for windows?

thanks,
alex.


April 18, 2007 | 10:44 pm

Yes, It’s on my share page along with the latest version of jit.gl.lua
which is required for using it on Windows. I’ve heard of one case of
debug DLL errors but haven’t been able to verify them myself. If you
install jit.gl.lua beta2 on windows and have issues with this please
let me know.

thanks,
wes

On 4/18/07, alexandre burton wrote:
>
> hello wes,
>
> jit.gl.lua rocks.
>
> any plan on getting the lua ode.so module compiled for windows?
>
> thanks,
> alex.
>
>


May 2, 2007 | 3:53 pm

Hi !
I have tried to install jit.gl.lua on Windows, but failed. I cannot instanciate [jit.gl.lua], but instead get the following error :

The application has failed to start because MSVCR71.dll was not found. Re-installing the application may fix the problem.
Error 126 loading external jit.gl.lua

Anyone has an idea on how to fix this. I have set the path properly, as far as I know. Maybe the lua DLL is missing. The .so is for Mac only, right?

Below are the steps I have followed to install [jit.gl.lua] on Windows :

- download from http://www.cycling74.com/twiki/bin/view/Share/WesleySmith
- put jit.gl.lua.mxe in C:Program FilesCycling ’74MaxMSP 4.6Cycling ’74jitter-externals
- put the help patch and script in the help folder in C:Program FilesCycling ’74MaxMSP 4.6max-helpjitter-help folder
- put the lua folder in C:Program FilesCycling ’74MaxMSP 4.6Cycling ’74
- put the lua51.dll in C:Program FilesCycling ’74MaxMSP 4.6support
- add ".Cycling ’74jitter-externals" in your path


May 2, 2007 | 4:41 pm

Hi Alexandre,
I was finally able to find this problem and fix it. I mistakenlyhad a
debug dll in my linker input for jit.gl.lua. Try this new version:

http://www.mat.ucsb.edu/~whsmith/jit.gl.lua.zip

I’m going to update my share page in a bit.

wes

On 5/2/07, Alexandre Quessy wrote:
>
> Hi !
> I have tried to install jit.gl.lua on Windows, but failed. I cannot instanciate [jit.gl.lua], but instead get the following error :
>
> The application has failed to start because MSVCR71.dll was not found. Re-installing the application may fix the problem.
> Error 126 loading external jit.gl.lua
>
> Anyone has an idea on how to fix this. I have set the path properly, as far as I know. Maybe the lua DLL is missing. The .so is for Mac only, right?
>
> Below are the steps I have followed to install [jit.gl.lua] on Windows :
>
> – download from http://www.cycling74.com/twiki/bin/view/Share/WesleySmith
> – put jit.gl.lua.mxe in C:Program FilesCycling ’74MaxMSP 4.6Cycling ’74jitter-externals
> – put the help patch and script in the help folder in C:Program FilesCycling ’74MaxMSP 4.6max-helpjitter-help folder
> – put the lua folder in C:Program FilesCycling ’74MaxMSP 4.6Cycling ’74
> – put the lua51.dll in C:Program FilesCycling ’74MaxMSP 4.6support
> – add ".Cycling ’74jitter-externals" in your path
>


May 2, 2007 | 4:49 pm

That didn’t take long :] share page updated. Let me know if you still
have problems.

thanks,
wes

On 5/2/07, Wesley Smith wrote:
> Hi Alexandre,
> I was finally able to find this problem and fix it. I mistakenlyhad a
> debug dll in my linker input for jit.gl.lua. Try this new version:
>
> http://www.mat.ucsb.edu/~whsmith/jit.gl.lua.zip
>
> I’m going to update my share page in a bit.
>
> wes
>
> On 5/2/07, Alexandre Quessy wrote:
> >
> > Hi !
> > I have tried to install jit.gl.lua on Windows, but failed. I cannot instanciate [jit.gl.lua], but instead get the following error :
> >
> > The application has failed to start because MSVCR71.dll was not found. Re-installing the application may fix the problem.
> > Error 126 loading external jit.gl.lua
> >
> > Anyone has an idea on how to fix this. I have set the path properly, as far as I know. Maybe the lua DLL is missing. The .so is for Mac only, right?
> >
> > Below are the steps I have followed to install [jit.gl.lua] on Windows :
> >
> > – download from http://www.cycling74.com/twiki/bin/view/Share/WesleySmith
> > – put jit.gl.lua.mxe in C:Program FilesCycling ’74MaxMSP 4.6Cycling ’74jitter-externals
> > – put the help patch and script in the help folder in C:Program FilesCycling ’74MaxMSP 4.6max-helpjitter-help folder
> > – put the lua folder in C:Program FilesCycling ’74MaxMSP 4.6Cycling ’74
> > – put the lua51.dll in C:Program FilesCycling ’74MaxMSP 4.6support
> > – add ".Cycling ’74jitter-externals" in your path
> >
>


May 2, 2007 | 5:07 pm

Hi wes,
thanks very much for this fix. I actually made it work meanwhile with http://www.dll-files.com/dllindex/pop.php?msvcr71d (it works now)

Now, what file do I need to put somewhere in my path to make the ODE extension for Lua work ? Now I get "module ODE is not found". Lua was looking for ".dll" and ".lua" files. The only binary included in a ".so" file, which is Mac only as far as I know.

Thanks for answering so fast !!

a


May 2, 2007 | 5:21 pm

On 4/18/07, Wesley Smith wrote:
>
> Yes, It’s on my share page along with the latest version of jit.gl.lua

Am I the only one who can’t find the windows version of luaODE?

-thijs


May 2, 2007 | 5:23 pm

On 5/2/07, Alexandre Quessy wrote:
>
>
> Now, what file do I need to put somewhere in my path to make the ODE
> extension for Lua work ? Now I get "module ODE is not found". Lua was
> looking for ".dll" and ".lua" files. The only binary included in a ".so"
> file, which is Mac only as far as I know.

Ah I guess that answers my question ;-)

-thijs


May 2, 2007 | 5:31 pm

So there is a new download of LuaODE with ode.dll. You place that in
c74/lua/luamods and things should be good.

wes

On 5/2/07, Alexandre Quessy wrote:
>
> Hi wes,
> thanks very much for this fix. I actually made it work meanwhile with http://www.dll-files.com/dllindex/pop.php?msvcr71d (it works now)
>
> Now, what file do I need to put somewhere in my path to make the ODE extension for Lua work ? Now I get "module ODE is not found". Lua was looking for ".dll" and ".lua" files. The only binary included in a ".so" file, which is Mac only as far as I know.
>
> Thanks for answering so fast !!
>
> a
>


May 2, 2007 | 5:31 pm

I should say the new download is on my share site.

wes


May 2, 2007 | 6:12 pm

Hi all,
The ode.dll was built against MSVCP71.dll, this time. I did download it from dll-files.com, but now, I get the following error on every frame:

lua pcall error [string "require("ode")..."]:67: argument 3 for dSpaceCollide must be a Lua function
print: memsize 197


May 2, 2007 | 6:22 pm

Hi !
Just a quick note to tell you it now works. Thanks !

Wes, it seems like the "jit.gl.lua_beta2.zip" download link is written twice on your share page.

a


May 2, 2007 | 6:31 pm

I see that dependency but I’m not sure how to get rid of it in the
visual studio project settings right now. As far as the error, do you
see this in function step():

function step()
ode.dSpaceCollide(space, nil, near)


end

near is a Lua function defined at the top of the script. when
dSpaceCollide gets called, it processes potential collisions and calls
back into the script with the function passed in as the 3rd argument.
In this case, it’s the near function.

wes

On 5/2/07, Alexandre Quessy wrote:
>
> Hi all,
> The ode.dll was built against MSVCP71.dll, this time. I did download it from dll-files.com, but now, I get the following error on every frame:
>
> lua pcall error [string "require("ode")..."]:67: argument 3 for dSpaceCollide must be a Lua function
> print: memsize 197
>
>


May 2, 2007 | 6:35 pm

Great. I fixed my page.
best,
wes

On 5/2/07, Alexandre Quessy wrote:
>
> Hi !
> Just a quick note to tell you it now works. Thanks !
>
> Wes, it seems like the "jit.gl.lua_beta2.zip" download link is written twice on your share page.
>
> a
>


Viewing 14 posts - 1 through 14 (of 14 total)