Forums > MaxMSP

wMax: can not reliably suspend the computer


_j
July 6, 2007 | 11:25 pm

hi maxers,

I have searched the forum trying to find if there is a solution to a power management problem I’m having on my XP machine. When I suspend the computer, and come back, Max will be using 100% CPU in task manager. Ive tried flipping audio on and off and open and closing patches but it stays stuck at 100%. Only closing down and reopening the application seems to fix it. Does anyone else experience similar behavior? Thanks.


July 6, 2007 | 11:37 pm

I have similar problems on a Toshiba Satellite with Centrino Duo T5200, XP SP2, and 2GB ram. I cannot go into hibernate or standby and expect max to work when I come back. For what it’s worth, this isn’t a problem for me; I just save and quit max before I re-open.


July 7, 2007 | 12:33 am

At 4:25 PM -0700 7/6/07, jamez wrote:
>I have searched the forum trying to find if there is a solution to a power management problem I’m having on my XP machine. When I suspend the computer, and come back, Max will be using 100% CPU in task manager. Ive tried flipping audio on and off and open and closing patches but it stays stuck at 100%. Only closing down and reopening the application seems to fix it. Does anyone else experience similar behavior? Thanks.

Have you tried turning off the Max scheduler before you suspend?

(fwiw, Max sleeps safely on a Mac)

-C


Chris Muir | "There are many futures and only one status quo.
cbm@well.com | This is why conservatives mostly agree,
http://www.xfade.com | and radicals always argue." – Brian Eno



_j
July 7, 2007 | 1:45 am

by turning off the scheduler, do you mean like turning off timing objects such as metro and such? I don’t have the documentation in front of me, but when I go home I’ll look at the ;max messages and see if something helps.

an update is that I think the problem only occurs when suspending for more than an hour. Ive suspended it a few times today and havent noticed the same thing. I suspended last night before going to bed and woke up to max at full CPU usage. DSP was off and the patch wasn’t using any timing events that I’m aware of.



_j
August 3, 2007 | 8:52 pm

Hello, I’m still experiencing a lot of problems with this. I noticed that if I leave the computer on standby, and come back, say around 4 hours, the CPU will be at 50% and stuck their until I send max a seteventqueue [i think thats the message] other than the value I currently have set. After the scheduler is changed, the cpu usage in task manager will come down back to 0%. HOWEVER, sometimes Max will be completely frozen when coming back and it is impossible to reset the scheduler in this way.

Is there an object that reports when a computer is about to go into standby? Also, how do you shut off the scheduler entirely? Would setting the interval to 0 do the trick?

james



_j
August 3, 2007 | 8:54 pm

Oh the reason why its stuck at 50% and not 100% is because its a dual core machine. thanks again.


August 3, 2007 | 10:10 pm

Quote: jamez wrote on Fri, 03 August 2007 14:54
—————————————————-
> Oh the reason why its stuck at 50% and not 100% is because its a dual core machine. thanks again.
—————————————————-

i dont know why you leave your machine in sleep mode
for 4 hours instead of turning it off, and i also dont
know what chris means with "turning the sheduler off".

but i guess you could turn the sheduler off by sending
the message "0" to both [adstatus overdrive] and
[adstatus switch].

i have seen various problems with wMax which were
releated to RAM fragmentation caused by patches,
some of them which had been working on the mac before.

-110



_j
August 3, 2007 | 10:29 pm

roman, my man, not only does it take much less time to come out of standby, but it also preserves whatever apps you’ve got open. couple that using only about 1.5 watts while suspended and you’ve got a much more effective and efficient setup for someone who only gets a few hours here and there to be in front of the computer. I rarely ever shut down anymore.

adstatus is MSP related. the scheuler i’m referring to is the Max scheduler, the ms timer, not the sample one. right now its set to every 2ms. the problem i’m having can sometimes be fixed by sending ";max seteventinterval X", where X is a new number to the value that’s already been set.

Please note that audio has been turned off to test whether or not its an audio problem. With audio off, max will still take up an entire core when coming out of a >2 hour standby on XP SP2. Very frustrating. thanks.


August 3, 2007 | 11:09 pm

the combination i suggested turns the sheduler off by
turning audio off and disabling the option "sheduler in
audio interrupt".

i dont know any other way to turn it off.
except creating a stack overflow, which is also very easy
to implement.


August 4, 2007 | 3:24 am

At 4:10 PM -0600 8/3/07, Roman Thilenius wrote:
>… i also dont
>know what chris means with "turning the sheduler off".

On the Mac, and maybe on Windows for all I know, typing Command period will halt the Max scheduler. A little dialog comes up that says something like "Select Resume to restart scheduler". This means that pretty much all of the event-level stuff is suspended.

Resume is at the bottom of the Edit menu, and on the Mac is Command R.

-C


Chris Muir | "There are many futures and only one status quo.
cbm@well.com | This is why conservatives mostly agree,
http://www.xfade.com | and radicals always argue." – Brian Eno



_j
August 4, 2007 | 4:17 am

interesting, I’ll go give it a try on the ole DAW………………………………….

okay, same on windows. I’ll give that a go whenever I suspend so I don’t have to shutdown max or the computer 0_o



_j
August 10, 2007 | 3:08 pm

Still the same. Stopping the scheduler with control+period before suspending doesn’t make a difference. When I come back from standby [or hibernate], max is using the entire core allocated to it and won’t free up most of the time unless the program is restarted. Sometimes, sending a ;max eventinterval with a new value other than what it’s set at will do the trick, but only sometimes.



_j
August 18, 2007 | 2:38 am

*BUMP*

this is a pretty serious issue for anyone that cares about their electric bills. Anyone at cycling care to do some research on this?


August 18, 2007 | 3:37 pm

At 7:38 PM -0700 8/17/07, jamez wrote:
>this is a pretty serious issue for anyone that cares about their electric bills. Anyone at cycling care to do some research on this?

Have you contacted Cycling74 support directly? I don’t know if they read every message on this forum.

-C


Chris Muir | "There are many futures and only one status quo.
cbm@well.com | This is why conservatives mostly agree,
http://www.xfade.com | and radicals always argue." – Brian Eno



_j
August 20, 2007 | 3:33 am

Well, andrew responded on the other thread. I’m going to get a laptop soon I think.. effectively making this an even more annoying bug :/


Viewing 15 posts - 1 through 15 (of 15 total)