won't record the audio

Feb 4, 2010 at 5:22am

won't record the audio

Im new to jitter. when i use “jit.qt.record” to record a quicktime video, i do not get audio? why is this? how do i record the audio ?

[MOD - removed uncompressed patch]

#48211
Feb 4, 2010 at 6:45am

sorry, havent posted a patcher in a while.

here is my patch:

– Pasted Max Patch, click to expand. –
#173376
Feb 4, 2010 at 7:47am

Check out jit.vcr.

#173377
Feb 4, 2010 at 7:57am

i will check out jit.vcr. also, when i record with jit.qt.record , the playback is very fast. how i do i get normal playback?

#173378
Feb 4, 2010 at 8:04am

To avoid this I believe you would need to set jit.qt.record’s @realtime attribute to 1.

AFAIK jit.vcr does not have this issue, as it always is in realtime mode in order to perform sync with the audio. Be sure to use spigot~ with jit.vcr if you want to capture the movie’s audio tracks.

#173379
Feb 4, 2010 at 8:56am

i tried setting it up but when i record , i get choppy playback and there is still no sound. i have posted my patcher, attempting to use jit.vcr for the first time. what am i doing wrong?

– Pasted Max Patch, click to expand. –
#173380
Feb 4, 2010 at 7:25pm

You need to specify a codec and framerate in the “write” message – see the jit.vcr help file. You also will probably need a very fast disk to record to if you want to work at 1280 x 720 resolution, depending on the QT codec you choose.

In terms of audio, from spigot~ help file:

“Under QuickTime 7, spigot~ no longer works via a Sound Ouput Component, due to changes in the QuickTime architecture. Instead, a sound file is exported from the loaded movie, cached, and played in sync.”

This means that if you have a very long source movie it may take some time for Max to export the audio to a separate file. This only needs to be done once.

#173381
Feb 4, 2010 at 7:53pm

i have a macbook pro. should be able to handle the 1280X720, right? I want the video to look clear when it is blown up on the computer. can i use a resolution smaller than 1280 X 720, that wont lose quality?

ALl I want is the video and audio to be synced into one mov file when i am done recording. Is there a way to do this with jit.qt.record? why wouldn’t jit.qt.record not be able to do this simple function?

#173382
Feb 4, 2010 at 8:23pm

jit.qt.record does not record audio, just video. jit.vcr is basically the same object with audio recording capability. The only major difference I see is that jit.vcr does not have a non-realtime mode, which shouldn’t affect you here.

It’s not possible to make blanket statements about what your computer should or should not be able to handle. It will depend on the particular codec/framerate that you’re using to record, the data rate that this choice implies, the CPU overhead of compressing the raw Jitter frames into that codec, and the write speed of the storage that you’re recording the file to. You’ll have to experiment on your particular system to find the right approach.

In other words, the fact that your computer can play/manipulate 1280×720 video in Max does not necessarily mean that it can record it at full resolution/frame rate. Welcome to Jitter.

#173383
Feb 4, 2010 at 9:43pm

thanks. i am getting a better understanding of how this works. i found settings that worked for me. records nice. one last problem still remains. i am not receiving audio. do i have the “spigot” set up correctly?

– Pasted Max Patch, click to expand. –
#173384
Feb 4, 2010 at 10:36pm

Patch looks fine to me.

As I said, if you have a long source movie it may take some time for Max to separate and cache the audio. Once this is done you should hear the audio play immediately, but you have to be patient and wait for the caching process to complete.

You should be able to see location of the cache file by sending spigot~ various cache messages – see spigot~’s reference page (upper right corner of the spigot~ help file).

#173385
Feb 5, 2010 at 9:40pm

I m sorry but i am still not receiving audio.

#173386
Feb 5, 2010 at 10:16pm

ok it’s working. thanks for your help. for some reason, it just started working. must be a glitch in my computer or something. thanks again!

#173387

You must be logged in to reply to this topic.