works in poly~ but not in poly~ in poly~

May 9, 2006 at 11:37am

works in poly~ but not in poly~ in poly~

While looking for a problem, I created a little ensemble: a sig~ (initialized to 1.) and a float go into a *~ and out to a signal monitor, so that the monitor reflects the float value, assuming that DSP is turned on.

I have a poly~ in a poly~, and here I get a value of 1. however wildly I change the value of float.

And I have not the foggiest.

Thanks,

Stuart

#25863
May 9, 2006 at 12:14pm

#76660
May 9, 2006 at 12:28pm

the patch is huge.

I’ve discovered something that is very puzzling. That little ensemble is in a patch called modHub~, which is loaded into a poly~ in a patch called voice~.

If I load modHub~ into a poly~ in a new document, everything is fine.

If I copy everything from voice~ to newDoc~, everything is fine.

When I rename newDoc~ to voice~, I get the old problem.

Anyone understand that ?

#76661
May 9, 2006 at 6:55pm

Stuart Grimshaw wrote:
> When I rename newDoc~ to voice~, I get the old problem.

Did you trash the old voice~? Max will load the first it can find.

Stefan

[][] [][][] [][] [][][]
[][][][][][][][][][][][][][][]

Stefan Tiedje
Klanggestalter
Electronic Composition
&
Improvisation

/~~~~~
\ /|() ()|
))))) )| | |( \
/// _/)/ )))))
___/ ///

————————-x—-
–_____———–|———–
–(_|_ —-|—–|—–()—-
– _|_)—-|—–()———–
———-()————x—–

14, Av. Pr. Franklin Roosevelt,
94320 Thiais, France
Phone at CCMIX +33-1-57 42 91 09

#76662
May 15, 2006 at 7:59pm

I did indeed trash the old one, and opened up the new one just to be absolutely sure.

However, the problem is fixed. Though I don’t know why, here’s how:

The problem arose after a new system (and hence Max) installation. The I/O buffer sizes were then on default (64 and 256, I believe). There is a loadmess message to modHub~ “down 32″. I disabled that – no problem. I reenabled that and set the buffers to 128 and 128 – again, no problem.

So problem solved, thank you for the help, and if anyone can explain that… ?

Stuart

#76663

You must be logged in to reply to this topic.