xbendin not working at all

Dec 4, 2012 at 3:25pm

xbendin not working at all

Hi guys,

I have a university assignment where the use of xbendin is preferential over bendin. Bendin works as expected outputting values. Xbendin however is not.

It doesn’t even output values in the example patch from the help file/tutorial.

Is this a known issue, is there something iffy with my setup, or have I just missed something?

I have checked everything I can think of, and found nothing relevant searching the forums.

I am using Max version 6.0.7



Dec 4, 2012 at 8:18pm

post a patch, that’s the only way anyone can help really

Dec 4, 2012 at 8:34pm


this very simple patch does not work.

If you want it I can add my assignment too.



– Pasted Max Patch, click to expand. –
Dec 4, 2012 at 9:13pm

it work fine at my end, stupid question but have you double clicked the midiin to select the midi device your using?

Dec 5, 2012 at 12:45am

That I did yes.

I am going to actually turn off the computer tonight and try again tomorrow. You never know.

Will also try in Max 5 that is still installed on my old laptop.

After all this it will be a dodgy pitch bend on my keyboard, or something to do with the alignment of the planets combined with the colour of the USB cable for a day.

Dec 5, 2012 at 1:31pm

A bit of progress.

All works as expected in Max 5 running on snow leopard.

I have been suffering random crashes with Max 6 and suspected it to be Mountain Lion related. I am going to completely remove max 6 and re-install to see if that makes any difference.

Fingers crossed.

Dec 5, 2012 at 8:20pm

I’m on mountain lion, no problems here. A fresh install can do wonders though!

Dec 9, 2012 at 12:41pm

I’ve had a few days testing now and xbendin is working in Max 6 after a complete removal and re-install.

Unfortunately Max is still crashing, but I have figured it is something to do with poly~ and modified read only edits (or whatever its called). Doing it the old fashioned way won’t cause a crash, anyway, that’s for anther topic.

Thanks for your input.



You must be logged in to reply to this topic.