xfade and uneven output from line

Feb 16, 2011 at 3:03pm

xfade and uneven output from line

I am trying to use Jitter to animate still images (1536 x 1024 pixels) by crossfading from one to another using xfade. The patch enclosed is what I am using to send values to xfade.

This all works in theory but I am finding that the values output from line are unpredictable. sometimes it runs smoothly from 0.0 to 1.0 and back again, sometimes it sticks and then picks up a bit later.

I’ve had a look at scheduling prefs and reduced scheduler slop to 1ms, overdrive is off. My mac is 2.5 Ghz, with 3 GB RAM.

Is it simply a case that my computer is not powerful enough to crossfade images of this size smoothly, or are there ways (I hope so !) that I can optimise MaxMSP to give a consistent smooth ramp of values from line, and hence a beautiful smooth crossfade ?

– Pasted Max Patch, click to expand. –

Thanks very much,

Jem

#54999
Feb 16, 2011 at 5:25pm

Have a look at Recipe 31 (Animator)– there’s a technique for using cpuclock to drive animations smoothly.

#198047
Feb 16, 2011 at 6:38pm

That looks promising, thanks for pointing me in its direction.

Jem

#198048
Feb 16, 2011 at 6:57pm

If one has to use metro to trigger cpuclock, is one then not back in the vagaries of timing that using cpuclock is trying to avoid ?

Thanks

Jem

#198049
Feb 16, 2011 at 9:24pm

line generally has more reliable timing with Overdrive turned on, i believe.

also, you might want to try bline instead of line.

#198050
Feb 16, 2011 at 10:43pm

Regarding overdrive, the “setting scheduler prefs” documentation advises leaving it off if you are primarily using Jitter, which I am. It seems to be better off.

I’ll have a look at bline, thanks.

#198051

You must be logged in to reply to this topic.