zl nth forgets previous arguments

Aug 6, 2008 at 10:11am

zl nth forgets previous arguments

Hi,

I ran into a problem again.
Here’s the situation:
-I’ve got a cellblock, refered to a coll.
-I want to update the data in a specific row, for specific columns

I tried to do this using zl iter and zl nth with an extra argument. But then I found out zl nth only remembers the last extra argument. Does someone has an idea on how to solve this?

I attached a patch of the situation.

Kind regards,
Bas

#39164
Aug 6, 2008 at 10:48am

Hi.
I don’t understand what you’re after but this should be the normal [zl
nth] behavior, as it accepts only one number in his right inlet (which
is the nth element of the list you want to output).
Maybe you should provide a clearer part of your patch ?

Ciao

#137507
Aug 6, 2008 at 5:09pm

On Aug 6, 2008, at 3:11 AM, Bas wrote:

> Does someone has an idea on how to solve this?

I’m not sure I understood the problem completely, but is this what you
want?

– Pasted Max Patch, click to expand. –

Chris Muir
cbm@well.com

http://www.xfade.com

#137508
Aug 7, 2008 at 10:10am

Hello Chris,

Yes, that was exactly what I meant.
I should really learn to work better with the trigger ;)
My temporary solution was to put the original list in a coll, like:
1 1
2 2
3 3
4 4

and then put the items of the changed list in it as well, like:
1 a
3 c

then dump the coll and put all of it back together.

It works, but your solution is much much easier.

Thank you very much!

Bas

#137509
Apr 1, 2012 at 5:20pm

Hello Chris and everyone else.

I am using this patch that you have made. But there is a limit at 256.
I am using your example for a dmx situation and want to be able to use 512 elements.

I am not sure how to solve this problem

Thanks

/Fredrik

#137510
Apr 1, 2012 at 9:39pm

I think the default size of zl lists is 256 elements, so if you want larger lists you just need to put a size argument in all your zl objects, prior to the mode argument ie [zl 512 nth 0]

#137511

You must be logged in to reply to this topic.