Forums > MaxMSP

zl sort bug?

August 26, 2006 | 8:31 am

Hi,

On Max/MSP 4.6.0, both Intel-Mac and PPC Mac, Mac OS 10.4.7,
(I’ve never tested it on 4.6.1)

I got "D A B" when I send "D B A" to "zl sort".
I got many similar results.
This could be a bug in zl.
(But I got "A B C" when I send "C B A" to the same object.)

It works fine on 4.5.7.

I’m sorry if it’s already known.

Thank you.

Best,
Masayuki Akamatsu


August 28, 2006 | 10:43 pm

I’m getting the same behavior with MaxMSP 4.6.1 on OSX 10.4.7, PB G4.
- David

————–

Summary: Alphabetic sorting is apparently broken for [zl sort] in
MaxMSP 4.6.1. Numeric sorting seems to work.

Expected Results: [zl sort] arranges a list received in its left
inlet in alphanumeric order.

Actual Results: Numeric elements are sorted correctly. Alphabetic
elements are not.

Steps to reproduce: See patch below.

max v2;
#N vpatcher 10 59 396 324;
#P window setfont "Sans Serif" 9.;
#P message 188 43 72 196617 z x y r a q t u;
#P message 127 44 58 196617 b 1 d 5.6 a;
#P message 6 24 57 196617 0.1 20 5;
#P message 51 80 103 196617 pants pickle pedantic;
#P message 40 63 31 196617 x d t;
#P window linecount 2;
#P message 27 142 37 196617 y x z q a r t u;
#P window linecount 1;
#P newex 27 122 62 196617 prepend set;
#P message 27 45 31 196617 d a c;
#P newex 27 102 40 196617 zl sort;
#P connect 8 0 0 0;
#P connect 7 0 0 0;
#P connect 1 0 0 0;
#P connect 4 0 0 0;
#P connect 5 0 0 0;
#P connect 6 0 0 0;
#P connect 0 0 2 0;
#P connect 2 0 3 0;
#P pop;

On Aug 26, 2006, at 4:31 AM, Masayuki Akamatsu wrote:

> Hi,
>
> On Max/MSP 4.6.0, both Intel-Mac and PPC Mac, Mac OS 10.4.7,
> (I’ve never tested it on 4.6.1)
>
> I got "D A B" when I send "D B A" to "zl sort".
> I got many similar results.
> This could be a bug in zl.
> (But I got "A B C" when I send "C B A" to the same object.)


August 30, 2006 | 12:33 am

Confirmed for me. 10.4.7, 4.6.1, MBP 2gig

mzed

Quote: David Stanford wrote on Mon, 28 August 2006 15:43
—————————————————-
> I’m getting the same behavior with MaxMSP 4.6.1 on OSX 10.4.7, PB G4.
> – David
>
> ————–
>
> Summary: Alphabetic sorting is apparently broken for [zl sort] in
> MaxMSP 4.6.1. Numeric sorting seems to work.
>


August 30, 2006 | 3:26 am

Thanks guys – I can reproduce.

-A


August 30, 2006 | 6:12 am

ok – fix will be in the next update. Ping me off list if you need it sooner.

-A


Viewing 5 posts - 1 through 5 (of 5 total)