Forums > MaxMSP

Zmap inverse mapping not working

November 15, 2009 | 1:44 pm

Is it me, or is the inverse mapping of zmap not working? (Max 5.1.0b8, OS 10.5.Cool. Something tells me this is an old issue, but I thought it had been fixed.

I only found this out because scale was behaving weirdly due to an abstraction called ‘scale’ in my search path, that was in fact just a wrapper for zmap – a big hands-up from me for Peter’s idea of a ‘Reveal in Finder’ button, which would have got me there a lot sooner,
cheers
Roger

PS. Where did that damn smiley appear from? I assure you, I did not put it there! Sort of thing that makes you nostalgic for the old list again…



nit
November 15, 2009 | 1:52 pm

Not sure what you mean by inverse mapping but i think [scale] will do.


November 15, 2009 | 2:58 pm

not not working, just not implemented.

[expr ((($f1-$f2)/($f3-$f2))*($f5-$f4))+$f4] will do it just fine.

p.s. the smiley is from the OS "10.5.8" and ")"



kjg
November 15, 2009 | 3:14 pm

"inverse mapping" has never worked with zmap.

zmap 0 127 0 1 and zmap 0 127 1 0 have always produced the same output.
inverting before or after scaling is an option:
!- 127
zmap 0 127 0 1

but scale does "invert", so why not use that?

best,
klaas-jan govaart


November 15, 2009 | 4:17 pm

I am using scale – as I said above, ‘scale’ stopped working for me for a while because it was really zmap, until I’d hunted down the rogue abstraction.
However, zmap.help states that it does do inverse mapping, so either zmap or it’s .help really should be changed,
cheers
Roger


November 15, 2009 | 5:20 pm

Hum… I can read that in zmap’s helpfile:

"For inverse data mapping, use the scale object – its hi and lo values can be reversed"


November 16, 2009 | 5:30 am
Emmanuel Jourdan wrote on Sun, 15 November 2009 18:20
"For inverse data mapping, use the scale object – its hi and lo values can be reversed"

that should be changed too then.

it should read: when you need a proper scale or map object, make your own.

_


Viewing 7 posts - 1 through 7 (of 7 total)