Alpha channel in gl.sketch


    May 25 2008 | 1:04 pm
    I can't get success using alpha channel in gl.sketch. "Color 1. 0. 0.
    0.2" is the same as "color 1. 0. 0. 1.", even in the jit.gl.sketch.help
    file...
    Is there an option to turn it on ?
    Thanks in advance
    f.e
    --
    f.e chanfrault | aka | personal computer music
    >>>>>>> http://www.personal-computer-music.com
    >>>>>>> | film soundtracks, sound art, music |

    • May 25 2008 | 1:30 pm
      sketch is reletivlly low level, you my have an easier time with a gridshape,
      this
      reset , glenable blend , glcolor 1. 0. 0. $1 , cube 0.2
      will give you alpha to sketch, watch the cmdlist with getcmdlist to see
      whats going on in sketch
      On Sun, May 25, 2008 at 4:04 PM, f.e wrote:
      > I can't get success using alpha channel in gl.sketch. "Color 1. 0. 0. 0.2"
      > is the same as "color 1. 0. 0. 1.", even in the jit.gl.sketch.help file...
      >
      > Is there an option to turn it on ?
      >
      > Thanks in advance
      >
      > f.e
      >
      > --
      > f.e chanfrault | aka | personal computer music
      > >>>>>>> http://www.personal-computer-music.com
      > >>>>>>> | film soundtracks, sound art, music |
      >
    • May 25 2008 | 1:44 pm
    • May 25 2008 | 2:12 pm
      make sure you have blend_enabled set to 1 in gl.render
      On Sun, May 25, 2008 at 3:04 PM, f.e wrote:
      > I can't get success using alpha channel in gl.sketch. "Color 1. 0. 0. 0.2"
      > is the same as "color 1. 0. 0. 1.", even in the jit.gl.sketch.help file...
      >
      > Is there an option to turn it on ?
      >
      > Thanks in advance
      >
      > f.e
      >
      > --
      > f.e chanfrault | aka | personal computer music
      >>>>>>>> http://www.personal-computer-music.com
      >>>>>>>> | film soundtracks, sound art, music |
      >
    • May 25 2008 | 2:15 pm
    • May 26 2008 | 6:50 am
      the glcolor's alpha-value has to be set to something else than 1., too.
      see patch below
      hth
      /*j
      > I'm sending "reset, glclearcolor 1. 1. 1. 1., glclear, glenable
      > blend, moveto 0. 0., glcolor 0.5 0.7 0.8 1., circle 0.1" to
      > jit.gl.sketch but still no alpha channel...
    • May 26 2008 | 12:45 pm
    • May 26 2008 | 5:31 pm
      For this approach you will need to select the blend mode you want and
      include it in the command list:...
      glenable blend;
      glblendfunc ;(for example 6 1)
      circle 0.1;
      ...
      pelado
      On Sun, May 25, 2008 at 3:44 PM, f.e wrote:
      > Thanks, Yair. I'm sending "reset, glclearcolor 1. 1. 1. 1., glclear,
      > glenable blend, moveto 0. 0., glcolor 0.5 0.7 0.8 1., circle 0.1" to
      > jit.gl.sketch but still no alpha channel...
      >
      > Is there something i have to do with the jit.gl.render and / or the
      > jit.pwindow too ?
      >
      > Best
      >
      > f.e
      >
    • May 26 2008 | 6:11 pm
      looks like it defaults to 1 6,
      On Mon, May 26, 2008 at 8:31 PM, pelado wrote:
      > For this approach you will need to select the blend mode you want and
      > include it in the command list:...
      > glenable blend;
      > glblendfunc ;(for example 6 1)
      > circle 0.1;
      > ...
      >
      > pelado
      >
      >
      > On Sun, May 25, 2008 at 3:44 PM, f.e > wrote:
      >
      >> Thanks, Yair. I'm sending "reset, glclearcolor 1. 1. 1. 1., glclear,
      >> glenable blend, moveto 0. 0., glcolor 0.5 0.7 0.8 1., circle 0.1" to
      >> jit.gl.sketch but still no alpha channel...
      >>
      >> Is there something i have to do with the jit.gl.render and / or the
      >> jit.pwindow too ?
      >>
      >> Best
      >>
      >> f.e
      >>
      >
      >
      >
      >