Audio glitches when using computer keyboard


    Jan 05 2008 | 3:27 pm
    Dear Maxers!
    Currently I am working on a new piece for live input (electric guitar) which is processed in realtime by a generative Max/MSP patch.
    Whenever I hit a key on the computer's keyboard or even touch the trackpad after a certain time (say: 1 minute), the audio output produces a noticable audio glitch.
    It seems to me as if the computer was falling in a sort of sleep mode and the glitch were the side effect of its awakening.
    Changing the performance parameters of Max (Overdrive, Scheduler in audio interrupt, various settings for I/O and Signal Vector Sizes) and also the "Energy Saver" of the System Preferences did not help.
    Here's my system configuration:
    * MacBook Pro (2.16 GHz, 2 MB RAM, OSX 10.4.11) * Edirol UA-25 Audio Interface
    Any ideas that could help?
    Thanks in advance,

    • Jan 05 2008 | 6:14 pm
      1. Have you got any firewire devices attached? I had a similar problem in that it kept falling asleep becasue of a LaCie drive attached via firewire. I changed it to USB2 and fixed. The timing you mentions is about right (1 minute). No audio glitches but display would go. I would then have to force it to sleep and out and do a restart which would normally fix it. Energy saver was off.
      Using terminal
      2. Is "safe sleep" mode on? to turn off: sudo pmset -a hibernatemode 0;sudo rm /var/vm/sleepimage
      3. A lot of problems I had recently went away affter purging Ds_stores. I.e the weird behaviours I mentioned acouple of weeks ago. YOU LOOSE THE STATE OF WINDOWS LIKE COLUMN VIEW ETC BUT SMALL PRICE TO PAY:
      echo -n 'CLIX cleaning .DS_Store files... ';sudo find / -name .DS_Store -exec rm -f {} ;;echo done.
      4. Turn all animations off.?: defaults write com.apple.finder DisableAllAnimations -bool YES;killall Finder
      A lot of finder problems where put right by number 4
      Sorry no clear answer from me. P
      On 05/01/2008, Karlheinz Essl wrote: > > Dear Maxers! > > Currently I am working on a new piece for live input (electric guitar) which is processed in realtime by a generative Max/MSP patch. > > Whenever I hit a key on the computer's keyboard or even touch the trackpad after a certain time (say: 1 minute), the audio output produces a noticable audio glitch. > > It seems to me as if the computer was falling in a sort of sleep mode and the glitch were the side effect of its awakening. > > Changing the performance parameters of Max (Overdrive, Scheduler in audio interrupt, various settings for I/O and Signal Vector Sizes) and also the "Energy Saver" of the System Preferences did not help. > > Here's my system configuration: > > * MacBook Pro (2.16 GHz, 2 MB RAM, OSX 10.4.11) > * Edirol UA-25 Audio Interface > > Any ideas that could help? > > Thanks in advance, > > Karlheinz Essl > http://myspace.com/karlheinzessl >
      -- A Pereshaped definition of an Apple: "You will never know what size worm is in your next byte"!
    • Jan 05 2008 | 6:18 pm
      Apologees, I meant number 3 not number 4. duh!! number 3 is a one line command not two
      On 05/01/2008, Pere Josep Villez wrote: > 1. Have you got any firewire devices attached? I had a similar problem > in that it kept falling asleep becasue of a LaCie drive attached via > firewire. I changed it to USB2 and fixed. The timing you mentions is > about right (1 minute). No audio glitches but display would go. I > would then have to force it to sleep and out and do a restart which > would normally fix it. Energy saver was off. > > Using terminal > > 2. Is "safe sleep" mode on? > to turn off: > sudo pmset -a hibernatemode 0;sudo rm /var/vm/sleepimage > > 3. A lot of problems I had recently went away affter purging > Ds_stores. I.e the weird behaviours I mentioned acouple of weeks ago. > YOU LOOSE THE STATE OF WINDOWS LIKE COLUMN VIEW ETC BUT SMALL PRICE TO > PAY: > > echo -n 'CLIX cleaning .DS_Store files... ';sudo find / -name > .DS_Store -exec rm -f {} ;;echo done. > > 4. Turn all animations off.?: > defaults write com.apple.finder DisableAllAnimations -bool YES;killall Finder > > A lot of finder problems where put right by number 4 > > > Sorry no clear answer from me. P > > On 05/01/2008, Karlheinz Essl wrote: > > > > Dear Maxers! > > > > Currently I am working on a new piece for live input (electric guitar) which is processed in realtime by a generative Max/MSP patch. > > > > Whenever I hit a key on the computer's keyboard or even touch the trackpad after a certain time (say: 1 minute), the audio output produces a noticable audio glitch. > > > > It seems to me as if the computer was falling in a sort of sleep mode and the glitch were the side effect of its awakening. > > > > Changing the performance parameters of Max (Overdrive, Scheduler in audio interrupt, various settings for I/O and Signal Vector Sizes) and also the "Energy Saver" of the System Preferences did not help. > > > > Here's my system configuration: > > > > * MacBook Pro (2.16 GHz, 2 MB RAM, OSX 10.4.11) > > * Edirol UA-25 Audio Interface > > > > Any ideas that could help? > > > > Thanks in advance, > > > > Karlheinz Essl > > http://myspace.com/karlheinzessl > > > > > -- > A Pereshaped definition of an Apple: > "You will never know what size worm is in your next byte"! >
      -- A Pereshaped definition of an Apple: "You will never know what size worm is in your next byte"!