bad performance in fullscreen mode


    Sep 13 2013 | 4:29 pm
    I'm working with a mxj sending drawing commands to jit.gl.slab. If i switch to fullscreen my frame rate get reduced by more then 20 fps. Instead if I stretch the window to the size of my screen I retain the normal frame rate. I remember that there was a thread years ago (can't find it right now) with the same issue, but I'm wondering if this bug is still alive in jitter and if there is a fix for that?
    Thanks

    • Sep 13 2013 | 5:07 pm
      How about when you set jit.window with (size 1920 1080, pos 0 0)? It is known that this performs better than the fullscreen option.
    • Sep 14 2013 | 10:20 am
      Make sure that your source is the same resolution as your output. If fullscreen is 1440 x 900 then make sure that the output of mxj. is also 1440 x 900. Resizing videos will always slow down the Fps rate. Also make sure that everything in your patch is triggered by one metro. This can also help a lot.
    • Sep 14 2013 | 12:14 pm
      thanks for the input guys!
      "How about when you set jit.window with (size 1920 1080, pos 0 0)? " can't see any improvements.
      "If fullscreen is 1440 x 900 then make sure that the output of mxj. is also 1440 x 900"
      I just send the drawing commands to sketch from my mxj, so there is no framesize, and then I render jit.gl.sketch to texture with the same size.
    • Sep 14 2013 | 3:33 pm
      i think we need to see your patch to give any useful advice