bitmap material on OBJ ( jit.gl.model ) export from blender software


    Jan 04 2012 | 12:57 pm
    hi guys!
    searched all over the forum and I can't find the method for proper exporting a WAVEFRONT OBJ from blender - so that jit.gl.model can import it properly with bitmap materials.
    I have checked for the apple.obj example - when I replace the filename (skin.tif) in the material file apple.mtl with my own bitmap it recognises it OK.
    But HOW TO EXPORT OBJ FROM BLENDER 2.61 in order for max 5 to read it nicely with bitmaps properly recognised?
    Any ideas?
    Thanks!!!
    Dariusz
    P.S. here's what I have in my OBJ and MTL files:
    CUBETEST.OBJ
    '
    # Blender v2.61 (sub 0) OBJ File: 'untitled.blend'
    # www.blender.org
    mtllib CUBETEST.mtl
    o Cube
    v 1.000000 -1.000000 -1.000000
    v 1.000000 -1.000000 1.000000
    v -1.000000 -1.000000 1.000000
    v -1.000000 -1.000000 -1.000000
    v 1.000000 1.000000 -0.999999
    v 0.999999 1.000000 1.000001
    v -1.000000 1.000000 1.000000
    v -1.000000 1.000000 -1.000000
    g Cube_Cube_Material
    usemtl Material
    s off
    f 1 2 3 4
    f 5 8 7 6
    f 1 5 6 2
    f 2 6 7 3
    f 3 7 8 4
    f 5 1 4 8
    '
    CUBETEST.MTL
    '
    # Blender MTL File: 'untitled.blend'
    # Material Count: 1
    newmtl Material
    Ns 96.078431
    Ka 0.000000 0.000000 0.000000
    Kd 0.640000 0.640000 0.640000
    Ks 0.500000 0.500000 0.500000
    Ni 1.000000
    d 1.000000
    illum 2
    map_Kd calosc22.jpg
    '

    • Jan 04 2012 | 5:23 pm
      hi. your model and material files look fine to me.
      what's not working?
    • Jan 10 2012 | 2:30 pm
      dear robert,
      thank you for your reply.
      the problem is that there's no picture (material) visible when I open my model in jit.gl.model in jitter.
      I get the object but without the texture.
      please find another example of the same problem in the attachment - I also included the setting screenshots of what i have in blender upon export.
      I can't figure out what am I doing wrong???
    • Jan 10 2012 | 3:16 pm
      hi Dariusz-- you need to uv map your image in blender in the UV image editor. In your first screenshot the mapping has to be coordinates set to UV. Attached are screenshots-- my diffuse influence is set to alpha for transparency.
      [attachment=181660,3188] [attachment=181660,3189]
    • Jan 10 2012 | 4:01 pm
      maaaaan!! it works now!! :)
      thanks a bilion times!
      it was such a pain really!!!
      thank you very much !! :)
      I'll play with the UV settings in blender now for different results!
      Kind Regards
      Dariusz