ALIAS (bug in pattrstorage) ?


    Oct 04 2013 | 12:35 pm
    Hello, i have a new error I didn't get before (max5 & max6.1).
    To reproduce just launch the help file provided.
    You'll get a "pattrstorage: alias must be unique" message in the max window.
    What is it ?
    Why ?
    Thx

    • Oct 04 2013 | 12:37 pm
      And here's the attachment.
    • Oct 06 2013 | 12:08 am
      i have the same message, not sure why.
    • Oct 06 2013 | 4:18 am
      Explicitly set the name of the pattr object using the @name syntax. That seems to fix it.
    • Oct 06 2013 | 7:45 am
      Yeah METAMAX, thx.
      And also maybe I found what happen:
      On launch, first alias is set by loadbang, then pattstorage recall alias saved in it. if it's the same, you'll get error message.
    • Oct 06 2013 | 7:54 am
      @METAMAX: after testing, it doesn't fix at all...
      I don't know exactly how to reproduce but after several "store preset", "save patch" and "reopen". the message appears again.
      But now I'm quite sure where is the problem:
      0- open Test-preset.maxhelp
      1a- alias is set in pattrstorage with a loadbang -> configA
      2- SAVE the patch
      3- when you launch the patch again : first alias is set by loadbang (configA), second pattstorage recall alias saved in it (configA).
      -> if it's same you have the error message.
      now
      0- open Test-preset.maxhelp
      1b- then SET alias with a message -> configB or configC
      2- SAVE the patch
      3- when you launch the patch again : first alias is set by loadbang (configA), second pattstorage recall alias saved in it (configB or configC).
      -> you can see alias is not this one loadbanged but this one who was saved (configB or configC), then there's not error message but alias is wrong.
    • Oct 06 2013 | 8:35 am
      Well one thing is for sure.. patterstorage is confusing.
      Not sure if this would work but have you tried using [closebang] or a combination of [closebang] and [loadbang] to handle the conflict?
    • Oct 06 2013 | 8:37 am
      No I didn't. Just I stopped using alias... It was only for two pattr in a patch, so...
    • Nov 01 2014 | 5:28 pm
      another bug with alias :