[bug?] jit.gl.node error message


    Aug 19 2013 | 12:44 pm
    Hi,
    I want to send "drawto" message to change the jit.gl.node target. All works fine but there is a bad message in the max window : " method getname called on invalid object "
    May be it's not the good way to do that ?????
    here is the patch (MBP retina, OS 10.8.4, Max 6.1.3) :
    Thanks

    • Aug 19 2013 | 6:31 pm
      i don't see anything wrong with what you're doing, so it looks like a bug. seems to be harmless, so i wouldn't worry for now.
      we'll take a look at the cause. thanks for the report!
    • Aug 19 2013 | 10:58 pm
      OK, Thanks Rob ;-)
    • Jul 22 2015 | 9:19 am
      Hi, The above patch doesn't work in Max7.0.4.... is it a bug ? thanks
    • Jul 22 2015 | 11:18 pm
      i can't reproduce. please send system specs and OS.
    • Jul 23 2015 | 1:24 pm
      Hi Rob,
      Sorry, i forgot to send this : MPB Retina mid-2012, OSX 10.10.4, Max 7.0.4 the Jit.window stay black..... and no message in the max console window.
      Thanks
    • Jul 23 2015 | 10:44 pm
      It works for me Max 7.04 MBP Retina, Mid 2014 OSX 10.9
    • Jul 27 2015 | 5:26 pm
      possibly a yosemite issue. will take a look when i get a chance.
    • Jul 27 2015 | 7:07 pm
      in order to get this patch working on yosemite, you should remove the @shared_context attribute from jit.gl.render. this attribute is deprecated, and no longer needed to enable shared contexts. simply use @shared 1 on the jit.(p)windows that are sharing gl resources.
    • Jul 28 2015 | 1:13 pm
      Thanks Rob !