Bug report: jit.gl.slab on 1.5.3rc2/osx 10.4.8


    Nov 17 2006 | 10:29 pm
    Hi, not completely sure if this is a bug or if it is my machine.
    Summary:
    Jitter tutorial patch 43jYourVeryOwnSlab instantly crashes my
    powerbook (max 4.5.7/jitter 1.5.3 rc2 and os x 10.3.9) when I turn on
    the qmetro attached to the jit.gl.render after loading 43j-
    fourwaymix.jxs. It also instantly crashes for any shaders I've been
    using that are variations on that shader code, which is a huge
    problem... It worked fine until the 1.5.3rc2 upgrade. I have no
    other problems in 1.5.3.
    Expected behavior:
    To load a shader and mix 3 (or more) texture image sources on the gpu
    Observed behavior:
    crrrrrasssssshhhh!
    Regression:
    Crash does not occur on my 10.4.8 machine, also with max 4.5.7/jitter
    1.5.3 rc2. Patch performs as expected on that machine.

    • Nov 29 2006 | 10:25 am
      Not to be a pain, but has there been any luck with this bug?
      Is it just my 10.3.9 machine?
      I will have to upgrade to 10.4 eventually, but I have performances
      that use this shader and 1.5.3rc2 is much prefeable with it's
      enhanced (and fixed) opengl support.
      thanks,
      evan
      On Nov 17, 2006, at 10:29 PM, evan.raskob [lists] wrote:
      > Hi, not completely sure if this is a bug or if it is my machine.
      >
      > Summary:
      >
      > Jitter tutorial patch 43jYourVeryOwnSlab instantly crashes my
      > powerbook (max 4.5.7/jitter 1.5.3 rc2 and os x 10.3.9) when I turn
      > on the qmetro attached to the jit.gl.render after loading 43j-
      > fourwaymix.jxs. It also instantly crashes for any shaders I've
      > been using that are variations on that shader code, which is a huge
      > problem... It worked fine until the 1.5.3rc2 upgrade. I have no
      > other problems in 1.5.3.
      >
      > Expected behavior:
      >
      > To load a shader and mix 3 (or more) texture image sources on the gpu
      >
      >
      > Observed behavior:
      >
      > crrrrrasssssshhhh!
      >
      >
      > Regression:
      >
      > Crash does not occur on my 10.4.8 machine, also with max 4.5.7/
      > jitter 1.5.3 rc2. Patch performs as expected on that machine.
      >