bugreport (involving crash): jit.qt.movie reports 'flatten 1' but..


    Nov 16 2006 | 12:29 pm
    jit.qt.movie reports 'flatten 1' but when I use that message to trigger the next flatten operation, it fails.
    - expected results: the patch will keep on flattening infinitly
    - actual results: flatten fails the second time.
    - steps to reproduce are in the patch.
    BUT, more important, after trying this patch, when I open the jit.qt.movie helpfile (by alt-clicking jit.qt.movie), Max crashes. This is reproducable.
    max 4.5.7, jitter 1.5.2, mac os x.4.8, G5 dual 2.5 GHz ppc
    Here are the first 4 crashreports:
    - Mattijs

    • Nov 16 2006 | 12:55 pm
      I can't reproduce your first issue: for me, with Jitter 1.6, it's all
      working, so you might try using the 1.5.3 beta to see if that takes
      care of the problem.
      I can reproduce the crash, however. I'll see if I can track that down.
      jb
      Am 16.11.2006 um 13:29 schrieb Mattijs Kneppers:
      > jit.qt.movie reports 'flatten 1' but when I use that message to
      > trigger the next flatten operation, it fails.
      >
      > - expected results: the patch will keep on flattening infinitly
      > - actual results: flatten fails the second time.
      > - steps to reproduce are in the patch.
      >
      > BUT, more important, after trying this patch, when I open the
      > jit.qt.movie helpfile (by alt-clicking jit.qt.movie), Max crashes.
      > This is reproducable.
      >
      > max 4.5.7, jitter 1.5.2, mac os x.4.8, G5 dual 2.5 GHz ppc
    • Nov 16 2006 | 1:58 pm
      Quote: Jeremy Bernstein wrote on Thu, 16 November 2006 13:55
      ----------------------------------------------------
      > I can't reproduce your first issue: for me, with Jitter 1.6, it's all
      > working, so you might try using the 1.5.3 beta to see if that takes
      > care of the problem.
      Ok, I'll check later. In fact the crash is the real problem and I'm happy I found a way to reproduce it in a simple patch. We experience a similar crash after simply flattening once when other stuff is running simultaneously. I could send you some crashreports of those if that helps.
      >
      > I can reproduce the crash, however. I'll see if I can track that down.
      That would be great.
      >
      > jb
      >