clip color code has changed in live 8.1.4 ?


    Jul 12 2010 | 4:17 pm
    when I get property "color" of a clip, the color code returned by Live.API has changed since Live 8.1.4 ;
    for ex, in Live 8.1.3 (and previous versions), first clip color code (red) was 9571075 ; now in 8.1.4, it is 15549221.
    The color code used in previous Live version used to match the color code used in JazzMutant Lemur (and it was very convenient !) ; now, the new color code looks almost the same, but much lighter.
    bug ? new feature ?
    what is the rule to convert this code to RGB ?
    should I modify all my patches & devices using this new code, .. or wait for a fix ?
    //I've posted this question to the Ableton forum as well : http://forum.ableton.com/viewtopic.php?p=1160602#p1160602 and got no reply //
    thanks in advance
    Mathieu
    _________________
    ________________
    Mathieu Chamagne
    http://mathieuchamagne.com

    • Jul 12 2010 | 11:56 pm
      Bumpety bump.
    • Jul 15 2010 | 12:24 pm
      with Live 8.1.5b1 + Max 5.1.5(43003) : same problem...
      any hint ?
      thanks in advance
      Mathieu
      ________________
      Mathieu Chamagne
      http://mathieuchamagne.com
    • Jul 15 2010 | 10:19 pm
      from the ref:
      The RGB value of the clip's color in the form 0x00rrggbb or (2^16 * red) + (2^8) * green + blue, where red, green and blue are values from 0 (dark) to 255 (light).
      You can use a simple js script to unpack this:
      function hex2rgb(hex){
      var r = (hex & 0xff0000) >> 16;
      var g = (hex & 0x00ff00) >> 8;
      var b = hex & 0x0000ff ;
      outlet(0, r, g, b);
      }
      Or do it with Max objects:
    • Jul 16 2010 | 3:16 pm
      Thanks Ben for the tip ; but this js / patch works fine with Live
      Mathieu
    • Jan 13 2014 | 9:21 am
      Thanks Ben/Mathieu. Just found this and using it in M4L 6.1.5 / Live 9.1.... working fine.
      Nick