Compiling with Cygwin c++ (windows)

    Aug 14 2011 | 3:11 pm
    I've been trying to compile any examples with Cygwin, it compile and the .mxe file is there but when i open it in max the box is always "dark" and there is no input or output to the box. It also doesn't say No Such Object in the max window so i guess these just a little something i'm not doing but i can't find what.
    I'm using these command like the API help says.
    gcc -c -mno-cygwin -DWIN_VERSION -DWIN_EXT_VERSION -IC:/MaxSDK-5.1.7/c74support/max-includes test.c
    gcc -shared -mno-cygwin -o test.mxe test.o test.def -LC:/MaxSDK-5.1.7/c74support/max-includes -lMaxAPI

    • Aug 14 2011 | 6:48 pm
      I put the .mxe file in the C:Program Files (x86)Cycling '74Max 5.0Cycling '74max-externals folder and also tried in the same folder of the max patch.
      I just tried to add it in the search path and it still doesn't work.
      I said that it doesn't say No Such Object because if i try a random name its does it but not with my object so i guess these something i'm not doing right
    • Aug 15 2011 | 10:17 am
      Did you try building the "collect" example in the SDK, following the instructions that come with that example? Does that work?
      Cheers, Tim
    • Aug 16 2011 | 8:00 pm
      I just tried with gcc and with codeblocks and when i open it is max is says that libstdc++-6.dll is missing. It must be something i didn't do from the help file.
      what should i edit with the $ e fstab.. ?
      is this the easiest way to do it on windows ?
    • Aug 16 2011 | 8:22 pm
      OK i got it! I did something wrong with the version when fallowing the help file. Thanks for the help
      Do you have a basic template for C++ ? Would it be easier to just do it in C ?
    • Aug 18 2011 | 12:40 pm
      The "collect" example in the SDK is what I would use as a template. But maybe I don't understand your question?
      best, Tim