Crash with wave~


    Nov 14 2007 | 2:04 pm
    I get a reproducable crash when changing the reference of wave~ to a
    different buffer with the following stripped down patch (the original
    bigger version will crash faster...):
    Change the waveform and hit the bang - draw... It will crash sooner or
    later on my Powerbook OSX 10.4.10, Max 4.6.3 and also on an old Desktop
    Mac with OSX 10.3.9...
    It doesn't crash if I use the default buffer~, only after I changed
    it... I can also post a complete crash report if necessary...
    Stefan
    Thread 14 Crashed:
    0 wave~ 0x021f6614 wave_perform1 + 1216
    1 com.cycling74.MaxAudioAPI 0x0593417c dspchain_tick + 132
    (d_ugen.c:228)
    2 com.cycling74.MaxAudioAPI 0x059325e0 ad_process + 440 (ad.c:1850)
    3 com.cycling74.ad_coreaudio 0x06b49880 coreaudio_onedevice_ioproc
    + 276
    4 com.apple.audio.CoreAudio 0x91469cf4
    IOA_Device::CallIOProcs(AudioTimeStamp const&, AudioTimeStamp const&,
    AudioTimeStamp const&) + 376
    5 com.apple.audio.CoreAudio 0x91469a08
    HP_IOThread::PerformIO(AudioTimeStamp const&) + 532
    6 com.apple.audio.CoreAudio 0x91467a18 HP_IOThread::WorkLoop() + 1156
    7 com.apple.audio.CoreAudio 0x91467580
    HP_IOThread::ThreadEntry(HP_IOThread*) + 16
    8 com.apple.audio.CoreAudio 0x914583dc
    CAPThread::Entry(CAPThread*) + 96
    9 libSystem.B.dylib 0x9002bd08 _pthread_body + 96
    Thread 14 crashed with PPC Thread State 64:
    srr0: 0x00000000021f6614 srr1: 0x000000000200f030
    vrsave: 0x0000000000000000
    cr: 0x84244024 xer: 0x0000000020000000 lr:
    0x000000000593417c ctr: 0x000000000000003f
    r0: 0x0000000031ce8a00 r1: 0x00000000f0101880 r2:
    0x00000000021f1a00 r3: 0x0000000031ce89fc
    r4: 0x000000007ffffffe r5: 0x00000000ffffffff r6:
    0x00000000ffffffff r7: 0x00000000000000ff
    r8: 0x0000000021638104 r9: 0x0000000007af960c r10:
    0x0000000000000011 r11: 0x0000000007af8e4c
    r12: 0x00000000021f1afc r13: 0x0000000000000000 r14:
    0x0000000000000000 r15: 0x0000000000000000
    r16: 0x0000000000000000 r17: 0x0000000000000000 r18:
    0x0000000024000024 r19: 0x0000000021637c30
    r20: 0x00000000002fd968 r21: 0x00000000058b87c8 r22:
    0x0000000000000002 r23: 0x00000000021fe28c
    r24: 0x0000000007af8d58 r25: 0x0000000007af8d54 r26:
    0x0000000021604760 r27: 0x0000000000000040
    r28: 0x00000000021d28f0 r29: 0x0000000000000001 r30:
    0x0000000000000000 r31: 0x00000000021f1c30
    --
    Stefan Tiedje------------x-------
    --_____-----------|--------------
    --(_|_ ----|-----|-----()-------
    -- _|_)----|-----()--------------
    ----------()--------www.ccmix.com

    • Jan 12 2008 | 4:42 am
      I just spent about 3 hours scratching my head over this same problem -
      swapping out index for wave seems to fix it. I'm on a g4 iMac with
      Max 4.6.3.
      There's another thread on here about the same problem that seems to
      indicate this only happens on PPC macs... The thread title is
      "cellblock+wave~ crash max."
      Best,
      Erik
      On 11/14/07, Stefan Tiedje wrote:
      > I get a reproducable crash when changing the reference of wave~ to a
      > different buffer with the following stripped down patch (the original
      > bigger version will crash faster...):
      --
      music: www.hecanjog.com / www.cedarav.com
      community: www.luvsound.org / www.storycorps.net