enable $1 inside [poly~]


    Nov 26 2009 | 11:53 am
    Hello,
    I can't get the enable message to [jit.gl.videoplane] nor gridshape working inside [poly~]. The other messages like position or poly_mode work fine.
    Any idea?
    below the two patches.
    2.93 Ghz intel core 2 duo 4 Go 1067 Mhz DDR3 NVIDIA GeForce 9400M NVIDIA GeForce 9600M GT OSX 10.5.8 Max 5.1.0
    ____________save as "simple_test.maxpat"____________

    • Nov 27 2009 | 9:26 pm
      i've noticed this before. not sure why that is, but easiest solution is to choose a different message to mean enable, and use [substitute newmessage enable] inside the poly abstraction.
    • Nov 29 2009 | 11:07 am
      You can't send messages directly into a poly~ which have some meaning for the poly~ object. As the poly~ object responds to the enable message the poly~ receives the message, not the in object inside it.
      The solution is either to do as robtherich suggests, or to prepend a symbol to the front of the message like passmessage (or whatever you like), and then use a route inside the object to remove this symbol.
      The same goes for any of the messages that poly~ would responds to.
      Hope this clarifies,
      Alex
    • Nov 29 2009 | 7:49 pm
      Ok Alex, thanks. But I do not see any "enable" message available for [poly~], so there is a bug somewhere.
    • Nov 30 2009 | 4:40 pm
      enable is a generic message for dsp objects. It's the old way for disabling the audio process done in an object. So you can't receive the enable message in the poly~, using Robert's trick is the way to go.