error building standalone-app


    Sep 23 2007 | 11:44 am
    I've tried to build an application from a patch. The application works fine but I get an error-warning in the max (status) window: patcher: missing arguments for message "close" How can I resolve this? And is it possible to supress the max-window in the app?
    thanks for a hint
    ole

    • Sep 23 2007 | 12:13 pm
      Am 23.09.2007 um 13:44 schrieb Ole Schmidt:
      > And is it possible to supress the max-window in the app?
      uncheck "Status Window Visible at Startup" in the standalone inspector. i don't know however, to disable the window completely.
    • Sep 23 2007 | 12:59 pm
      On 23 sept. 07, at 14:13, tatama_suomo@yahoo.de wrote:
      >> And is it possible to supress the max-window in the app? > > uncheck "Status Window Visible at Startup" in the standalone > inspector. > i don't know however, to disable the window completely.
      There's a max message to disable it completely (from the Windows menu):
      ; max maxinwmenu 0
      ej
    • Sep 23 2007 | 1:21 pm
      > ; max maxinwmenu 0
      ----------------------------------------------------
      sorry I am new to max- where do I put the message (in what form)?
      thanks ole
    • Sep 23 2007 | 1:43 pm
      On 23 sept. 07, at 15:21, Ole Schmidt wrote:
      >> ; max maxinwmenu 0 > > ---------------------------------------------------- > > sorry I am new to max- where do I put the message (in what form)?
      You just needed to paste that in a message box. Otherwise just copy and paste the following piece of patch:
      HTH, ej
    • Sep 23 2007 | 2:02 pm
      that is what i did- pasting "; max maxinwmenu 0" in a message box inside my patch and connect it to a loadbang-object. Than I build a standalone app from the patch. When I doubleclick the app, the max-window (here called "status") appear on the screen. So it does not work?!
      (Now, I am on 4.5, because I don't get the error warning from my first post here)
      And how do I get a inspector-window in a standalone-app? (I'am on a mac, command-i does not work...)
      thanks for your patience
      ole
    • Sep 23 2007 | 2:12 pm
    • Sep 23 2007 | 3:44 pm
      finally I've got it
      thank you very much for your help!
      ole