file preference error


    Jan 27 2006 | 5:55 pm
    hi,
    im trying to set the path in the file preferences to
    an external hard drive without luck.it used to work
    fine on a PC but it wont on mac os 10.3.9.the hard
    drive is a lacie one.
    im reiceving this message: error -43 creating path
    did anyone came accross the same problem? or have a
    clue why?
    i googled and went to the forum but did not found a
    solution.
    thank you in advance
    j.

    • Jan 27 2006 | 7:03 pm
      Are there any apostrophes or slashes or other "unusual" characters in
      the path name?
      I've been frustrated on several occasions because I've had to remove
      apostophes from folder names in order to get something to work in Max.
      -- P.
      -------------- http://www.bek.no/~pcastine/Litter/ --------------
      Peter Castine | ^
      | Litter Power & Litter Bundle for Jitter
      pcastine@gmx.net |
      pcastine@bek.no | iCE: Sequencing, Recording, and Interface Building
      4-15@kagi.com | for Max/MSP
      | Extremely cool
      | http://www.dspaudio.com
      | http://www.dspaudio.com/software/software.html
    • Jan 27 2006 | 7:45 pm
      hi peter, thanx for the reply
      nothing unusual the path is brain/my docs/maxmsp
      j.
    • Jan 27 2006 | 8:20 pm
    • Jan 27 2006 | 8:59 pm
      hello,
      naming your folder mydocs should work indeed. or you can add quote to your path "mypath/my docs/etc" in Max prefs. That said, Max add quotes automaticaly, here. Strange if it doesn't on your computer.
      Julien.
    • Jan 27 2006 | 10:20 pm
      hi julien,
      followed your advice and now i get a different number
      in the error message
      thank you
      j.
    • Jan 27 2006 | 11:47 pm
      Well... not the result I expected ;-)
      Just to sum up.
      I created for test a folder named 'patch' here :
      30:/Users/julien/testpath/my docs/patch/
      Now, if I type this path in the Max pref window, I get :
      "error: filepath: 30:/Users/julien/testpath/my: error -43 creating path"
      Same result as you, isn't it ? Did you type your path, or did you choose your folder with the Choose button ? Max needs double quotes because of the blank space in your folder name. But with the Choose button, Max should add double quotes. At least it does here.
      Sorry for mostly repeating my previous message. Just trying to be sure I understand you correctly.
      What is the new error message you get ?
      Julien.
    • Jan 28 2006 | 12:03 am
      Quotes from posts are not added to messages or did I make something
      wrong ? mm... This new forum seems too much complicated for me... ;-)
      Julien
      Anyway. here it is again for mail list :
      Well... not the result I expected ;-)
      Just to sum up.
      I created for test a folder named 'patch' here :
      30:/Users/julien/testpath/my docs/patch/
      Now, if I type this path in the Max pref window, I get :
      "error: filepath: 30:/Users/julien/testpath/my: error -43
      creating path"
      Same result as you, isn't it ? Did you type your path, or did you
      choose your folder with the Choose button ? Max needs double quotes
      because of the blank space in your folder name. But with the Choose
      button, Max should add double quotes. At least it does here.
      Sorry for mostly repeating my previous message. Just trying to be
      sure I understand you correctly.
      What is the new error message you get ?
      Julien.
    • Jan 28 2006 | 9:26 am
      hi julian,
      for some reasons everything is fine today. however the
      MAX did not like the quotation marks.
      let me explain. yesterday i was choosing the hard
      drive using the button choose and i was getting the
      same error you mentioned in your reply. than i added
      quotes as you said and the error changed into -1
      instead of -43. this morning i was having the same
      problem so i plugged the hard drive to the pc to see
      if it works on a different platform. it did work fine
      on pc. i went back on mac again and it worked for some
      unknown reasons. but if i add quotes i get the same
      error message(...-1...).
      its odd isn`it.
      thank you very much for your helps.
      j.