getting one bang per state change


    Nov 13 2007 | 3:54 am
    Dear Wonderful Max List:
    I connected my arduino to max and initially I thought as long as
    I get a bang, everything would be fine. on my interface I have two kinds
    of switches, one's that stay in (like toggle in max) and others that
    only
    connect when I press (like bang objects). The button swithes have been
    working fine. however the toggle switches are always active despite the
    appearance -- that is even-though the state of the toggle changes to
    active
    or off, either way it is always banging. I would have originally
    hoped that once
    the toggle activates it sends a 1 or something (once!) which I could
    convert to
    bang and once it turns off, it would send a zero (only one zero), but
    It is always
    sending stuff. How can I get only one from all these... so how can
    get only one
    "0" from all these zero's coming in, and only one "1" from all the
    one. I have tried
    rout, select, and a number box and none of this worked?
    Thanks very much.
    Dean.

    • Nov 13 2007 | 3:03 am
      Try the change object?
      [ddg]
      Darwin Grosse
      On Nov 12, 2007, at 8:54 PM, Dean wrote:
      > Dear Wonderful Max List:
      > I connected my arduino to max and initially I thought as long as
      > I get a bang, everything would be fine. on my interface I have two
      > kinds
      > of switches, one's that stay in (like toggle in max) and others
      > that only
      > connect when I press (like bang objects). The button swithes have been
      > working fine. however the toggle switches are always active despite
      > the
      > appearance -- that is even-though the state of the toggle changes
      > to active
      > or off, either way it is always banging. I would have originally
      > hoped that once
      > the toggle activates it sends a 1 or something (once!) which I
      > could convert to
      > bang and once it turns off, it would send a zero (only one zero),
      > but It is always
      > sending stuff. How can I get only one from all these... so how can
      > get only one
      > "0" from all these zero's coming in, and only one "1" from all the
      > one. I have tried
      > rout, select, and a number box and none of this worked?
      > Thanks very much.
      > Dean.
    • Nov 13 2007 | 4:07 am
      look at [change] and/or [change~].
      On Nov 12, 2007, at 8:54 PM, Dean wrote:
      > Dear Wonderful Max List:
      > I connected my arduino to max and initially I thought as long as
      > I get a bang, everything would be fine. on my interface I have two
      > kinds
      > of switches, one's that stay in (like toggle in max) and others
      > that only
      > connect when I press (like bang objects). The button swithes have been
      > working fine. however the toggle switches are always active despite
      > the
      > appearance -- that is even-though the state of the toggle changes
      > to active
      > or off, either way it is always banging. I would have originally
      > hoped that once
      > the toggle activates it sends a 1 or something (once!) which I
      > could convert to
      > bang and once it turns off, it would send a zero (only one zero),
      > but It is always
      > sending stuff. How can I get only one from all these... so how can
      > get only one
      > "0" from all these zero's coming in, and only one "1" from all the
      > one. I have tried
      > rout, select, and a number box and none of this worked?
      > Thanks very much.
      > Dean.
      ----
      Steven M. Miller
      Professor, Contemporary Music Program
      College of Santa Fe
      Home
      SFIFEM
      Atrium Sound Space
      OVOS
      CMP
    • Nov 14 2007 | 1:42 am
      Thank you very much,
      It looks like it's gonna work.
      Dean.
      On Nov 12, 2007, at 11:07 PM, Steven Miller wrote:
      > look at [change] and/or [change~].
      >
      >
      > On Nov 12, 2007, at 8:54 PM, Dean wrote:
      >
      >> Dear Wonderful Max List:
      >> I connected my arduino to max and initially I thought as long as
      >> I get a bang, everything would be fine. on my interface I have two
      >> kinds
      >> of switches, one's that stay in (like toggle in max) and others
      >> that only
      >> connect when I press (like bang objects). The button swithes have
      >> been
      >> working fine. however the toggle switches are always active
      >> despite the
      >> appearance -- that is even-though the state of the toggle changes
      >> to active
      >> or off, either way it is always banging. I would have originally
      >> hoped that once
      >> the toggle activates it sends a 1 or something (once!) which I
      >> could convert to
      >> bang and once it turns off, it would send a zero (only one zero),
      >> but It is always
      >> sending stuff. How can I get only one from all these... so how can
      >> get only one
      >> "0" from all these zero's coming in, and only one "1" from all the
      >> one. I have tried
      >> rout, select, and a number box and none of this worked?
      >> Thanks very much.
      >> Dean.
      >
      > ----
      > Steven M. Miller
      > Professor, Contemporary Music Program
      > College of Santa Fe
      >
      > Home
      > SFIFEM
      > Atrium Sound Space
      > OVOS
      > CMP
      >
      >
    • Nov 17 2007 | 2:45 am
      Thank you very much.
      works like a charm (better than select, if/else, bang to toggle or
      vice versa).
      Dean.
      On Nov 14, 2007, at 9:28 AM, ddg@cycling74.com wrote:
      > Try the change object?
      >
      > [ddg]
      > Darwin Grosse
      >
      > On Nov 12, 2007, at 8:54 PM, Dean wrote:
      >
      >> Dear Wonderful Max List:
      >> I connected my arduino to max and initially I thought as long as
      >> I get a bang, everything would be fine. on my interface I have two
      >> kinds
      >> of switches, one's that stay in (like toggle in max) and others
      >> that only
      >> connect when I press (like bang objects). The button swithes have
      >> been
      >> working fine. however the toggle switches are always active despite
      >> the
      >> appearance -- that is even-though the state of the toggle changes
      >> to active
      >> or off, either way it is always banging. I would have originally
      >> hoped that once
      >> the toggle activates it sends a 1 or something (once!) which I
      >> could convert to
      >> bang and once it turns off, it would send a zero (only one zero),
      >> but It is always
      >> sending stuff. How can I get only one from all these... so how can
      >> get only one
      >> "0" from all these zero's coming in, and only one "1" from all the
      >> one. I have tried
      >> rout, select, and a number box and none of this worked?
      >> Thanks very much.
      >> Dean.