GuitarRig in MaxMSP ??


    May 19 2006 | 1:56 pm
    hi
    does any of you use the native instrument's GuitarRig 2 as vst plug
    in in max????
    i did somehow work for me for very simple guitarRig's patches
    (disto->amp->out) but i keep having problems
    1/ the object [vst~ "GuitarRig 2.vst"] makes max crash (i have to use
    the "plug" message)
    2/ using the splitter object in guitar Rig makes max crash (5 times
    in a row so far!!!)
    _by crash i mean max quits
    _i encounter those problems only with guitar rig2 (I can call the
    chosen plug-in by putting its name as argument EVEN with guitarRig 1
    - but the 2 makes max crash)
    _I of course did contact NI, but, nice and helpful as they always
    are, they told me they do not care much about C74, and that it is
    most certainly a C74 bug - which i don't think
    just curious to know if anybody did try/use this combination - if you
    have both max and GR2, it's a simple test, takes 5 seconds before the
    crash
    that's with my set-up, mac X.4.5, PBook 1.5, full or RAM, latest
    maxmsp, latest guitarRig
    thanks
    best
    kasper
    --
    Kasper T. Toeplitz
    noise, composition, bass, computer

    • May 19 2006 | 2:26 pm
      Seems to work pretty well on Windows - I'll install it on the mac here soon.
      Do you have crash logs for any of this?
      Thanks
      -A
    • May 19 2006 | 2:38 pm
      where do i find teh crashlog on a macOSX???
      for sure it did not propose to send a crashlog to apple, just crashed
      thanks
      kasper
    • May 19 2006 | 2:59 pm
      On 19 mai 06, at 16:38, Kasper T Toeplitz wrote:
      > where do i find teh crashlog on a macOSX???
      Hi,
      normaly it's here:
      ~/Library/Logs/CrashReporter/
      Best,
      ej
    • May 19 2006 | 3:02 pm
      Hey Kasper!
      one easy way to find the crash logs is to launch the "Console" app (it must be somewhere in your utility folder in your Applications folder).
      If you don't have a list of items on the left of the window, click on the "Logs" button.
      Choose ~/Library/Logs -> CrashReporter -> MaxMSP...
      There are many many things you can look at in Console, but I guess you prefer to play with virtual guitars...
      Have fun!
      p
    • May 19 2006 | 3:03 pm
      1. Open the Console Application (Applications/Utilities/Console).
      2. On the left side, in the Logs column, navigate to ~/Library/Logs, Crash reporter, MaxMSP 4.5.crash.log
      3. Select all the text of the log on the right side. Copy to clipboard.
      4. Paste clipboard into an email message and send to support@cycling74.com with a clear description of what it was you did ( numbered steps are great )
      You might want to clear it first so that you don't send us all of your crashes.
      -A
    • May 19 2006 | 3:12 pm
      Guitar Rig 2 works fine in my VSTi Host standalone, which is built
      with Max/MSP. I can call up patches that include the splitter
      object, with no problems.
      Dan
      --
      Dan Nigrin
      Defective Records
      202 Hack / PC-1600 User / VSTi Host / OMS Convert / Jack OS X
      http://www.defectiverecords.com
    • May 19 2006 | 3:19 pm
      >
      >
      >There are many many things you can look at in Console, but I guess
      >you prefer to play with virtual guitars...
      my bass is NOT virtual !!!!
      best
      kasper
      --
      Kasper T. Toeplitz
      noise, composition, bass, computer
    • May 19 2006 | 3:32 pm
      >Guitar Rig 2 works fine in my VSTi Host standalone, which is built
      >with Max/MSP. I can call up patches that include the splitter
      >object, with no problems.
      >
      and touch/turn the GRig knobs????
      Every time i try it, it crashes - the stand alone works however....
      and simple patches (no splitter) work.......... hummmmmmmmm
      thanks
      kasper
      --
      Kasper T. Toeplitz
      noise, composition, bass, computer
    • May 19 2006 | 3:47 pm
      Yeah, knob turning works too. One thing to note - the version of
      VSTi Host I'm using is the latest one, but it is built with Max/MSP
      4.5.3.
      I checked to see if it would work in 4.5.7 just now, and it did. So
      something not right on your system or in your patch??
      Dan
      --
      Dan Nigrin
      Defective Records
      202 Hack / PC-1600 User / VSTi Host / OMS Convert / Jack OS X
      http://www.defectiverecords.com
    • May 19 2006 | 4:04 pm
      thanks for your answers... BUT i just installed (right now) GRig 2 on
      another computer (iMac G5) which has pretty much the same set-up
      (OSX45, latest max, using the core audio for testing), re-did the
      patch (which is SO simple : noise~-> vst~->ezdac ) called Guitar Rig 2
      _after turnig a few knobs (some more than on my Pbook) the app (max) crashed
      it _might_ be because i connect the noise~ to both inputs of vst~
      .......???????????
      i send the crashlogs to C74 but it does not feel very secure.... in a
      live situation, i mean
      on my Pbook the cpu was at 25%, on the iMac (G5) at 22% .......
      many thanks
      kasper
    • May 19 2006 | 4:25 pm
      I reproduced your setup here, and can run it exactly the same noise~
      --> vst~ --> exdac, sending noise~ to both of vst~'s inputs.
      HOWEVER - I noticed that even in a simple patch with just a vst~
      object, and nothing else, I crash Max by typing vst~ "GuitarRig 2"
      directly into an object box. If I instead just type vst~ into an
      object box, and then do a plug "GuitarRig 2" message to the vst~, it
      loads it OK, and then works fine after that.
      Perhaps this helps C74 (or NI!) figure out the problem, not sure!
      HTH,
      Dan
      --
      Dan Nigrin
      Defective Records
      202 Hack / PC-1600 User / VSTi Host / OMS Convert / Jack OS X
      http://www.defectiverecords.com
    • May 19 2006 | 4:34 pm
      You should reconsider setting up your PC (GR works fine on mine), or
      forget about "splitter" for a while :-)
      best
      f.e
    • May 19 2006 | 4:39 pm
      yes, this i also reported
      it _seems_ i am in the middle of founding an answer: my "new" install
      (iMac) crashed, but only once - just after installing it. Could be
      some lack of prefs...
      however, after re-start, i tried again, and it worked - i redid all
      my steps, and it did NOT crash.
      then i realised than on the Pbook (my main machine) I did (at some
      point) the GRig update - so i tried to update it on my iMac, and ,
      yes, immadiate crash (talk about a cool update!!!)
      I updated using the one (dec 05) for os X.4 - now i am downloading
      the jan 06 update if i still have crashes i will downgrade to the
      install-CD state...
      many thanks
      kasper
      --
      Kasper T. Toeplitz
      noise, composition, bass, computer
    • May 19 2006 | 4:43 pm
      >You should reconsider setting up your PC (GR works fine on mine), or
      >forget about "splitter" for a while
      haha!!
      if i don't use splitter it means loading 2 GR's - too much for my
      Pbook ( my bass has 2 separate outputs)
      as for the PC i was seriously thinking about calling you !!
      best
      kasper
    • May 19 2006 | 7:35 pm
      Kasper T Toeplitz wrote:
      > my bass is NOT virtual !!!!
      but as soon as you start playing virtually everythings turns into bass...
      --
      Stefan Tiedje------------x-------
      --_____-----------|--------------
      --(_|_ ----|-----|-----()-------
      -- _|_)----|-----()--------------
      ----------()--------www.ccmix.com
    • May 19 2006 | 8:32 pm
    • May 19 2006 | 9:38 pm
      Kasper T Toeplitz wrote:
      > my bass is NOT virtual !!!!
      but as soon as you start playing, virtually everythings turns into bass...
      --
      Stefan Tiedje------------x-------
      --_____-----------|--------------
      --(_|_ ----|-----|-----()-------
      -- _|_)----|-----()--------------
      ----------()--------www.ccmix.com