Help pinning down Crash?


    Feb 08 2011 | 7:31 am
    I'm crashing a pretty massive mxj/max patch. It'll be pretty tough to pull apart and test. Wondering if this looks decipherable to anyone...
    Here's a sample from activity monitor.
    I'm running 10.6.6 and max 5.1.7
    This is also in the logs
    2/8/11 1:58:01 AM	MaxMSP[7160]	MaxMSP(7160,0xa0426540) malloc: *** error for object 0x170d8000: pointer being freed was not allocated
    *** set a breakpoint in malloc_error_break to debug
    2/8/11 1:58:01 AM	[0x0-0x4c34c3].com.cycling74.MaxMSP[7160]	MaxMSP(7160,0xa0426540) malloc: *** error for object 0x170d8000: pointer being freed was not allocated
    2/8/11 1:58:01 AM	[0x0-0x4c34c3].com.cycling74.MaxMSP[7160]	*** set a breakpoint in malloc_error_break to debug
    2/8/11 1:58:01 AM	[0x0-0x4c34c3].com.cycling74.MaxMSP[7160]	sqlite version 3.6.14.2
    2/8/11 1:58:08 AM	[0x0-0x4c34c3].com.cycling74.MaxMSP[7160]	Max: starting db update
    2/8/11 1:58:08 AM	[0x0-0x4c34c3].com.cycling74.MaxMSP[7160]	Max: unable to open [-psn_0_4994243]
    2/8/11 1:58:49 AM	Firewall[79]	Stealth Mode connection attempt to UDP 10.0.1.3:61668 from 10.0.1.1:53
    2/8/11 1:58:49 AM	Firewall[79]	Stealth Mode connection attempt to UDP 10.0.1.3:64636 from 10.0.1.1:53
    2/8/11 1:58:56 AM	[0x0-0x4c34c3].com.cycling74.MaxMSP[7160]	Max: db update complete
    2/8/11 2:29:54 AM com.apple.launchd.peruser.502[190] ([0x0-0x4c34c3].com.cycling74.MaxMSP[7160]) Exited with exit code: 143

    • Feb 16 2011 | 7:20 pm
      Apparently it has to do with this bug in leopards nvidia drivers... anyone else experiencing this?
      AM kernel NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
    • Feb 16 2011 | 9:50 pm
      can you post the crash report ?
    • Feb 16 2011 | 9:59 pm
      This typically happens.
      The only AWT object I use is Color... so I'm guessing something else is going on. Specifically, if I check the console for right before the crash, that NVDA line comes up(see above post). Possibly relevant: The OSCReceiver thing is in there and the console always seems to say something about stealth mode. I'm not sure if thats related.
      I can't tell if it's exactly the same because sometimes the entire machine freezes. The reason I only posted the one line was because I had to go back to the console. The reason I think my crash is similar to those at apple discussions is because it's been reported that the screen flickers before the crash. That happens to me too..
      That's really all I have. I could be in denial about having to rework the threading for my app though... that would be complicated.
    • Feb 18 2011 | 4:00 pm
      I tracked it down to erase/drawclients/swap so it appears to be crappy snow leopard graphics drivers... or cycling bug though I seriously doubt it.